Bug 54377 - vim-6.0-2 has missing statusline and corrupt cmdline
Summary: vim-6.0-2 has missing statusline and corrupt cmdline
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vim (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-05 07:58 UTC by Jordan Breeding
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-05 07:58:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jordan Breeding 2001-10-05 07:58:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.10-ac3-preempt-test i686)

Description of problem:
I always hack the latest vim package so that vim-minimal has +statusline so
that I can see where I am in a file, I do this by using
vim<version>/src/feature.h.  This is not terribly complicated, I then retar
the source and build my packages, and using vim-5.8-7 I get something like
"19,0-1        Top" at the bottom of every file.  In vim-6.0-2 one is now
required to set rulerformat using "set rulerformat=" in
/usr/share/vim/vim6.0/macros/vimrc if he/she wishes the statusline to be
anything except blank.  Could the next rawhide package be modified to
contain a default rulerformat equivalent to the old static rulerformat from
vim-5.8?  It would be greatly appreciated.  When writing a file from within
vi it always displays the filename and how many line and characters you
just wrote, this works but contains a bug such that if I do a ":wq" instead
of just quiting and not displaying that information it displays all of that
line minus what gets cut off by my new commandline so that after a ":wq" or
":wq!" using vim-6.0-2 my commandline for /bin/bash looks like this: '252
root@ledzep /usr/src > s/vimrc" 105L, 3622C written'.  This is very
annoying and I hope that it will be fixed soon, please fix these as these
bugs are keeping me from upgrading to vim-6.0 from vim-5.8.  Thank you.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Patch vim<version>/src/features.h to enable statusline in features=tiny
2. Start /bin/vi and notice that the ruler is non existent, set rulerformat
to something and watch it begin to work, realize that you liked the old
ruler and can't figure out the rulerformat string to make it work.
3. Start /bin/vi either by opening an existing file or writing in the
buffer and writing it to a file, then be sure the exit string for /bin/vi
is longer than your current commandline and do a ":wq" or a ":wq!", watch
it corrupt your commandline.
	

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-24 22:47:13 UTC
Works correctly in 6.0-12


Note You need to log in before you can comment on or make changes to this bug.