Bug 54380 - gcc crashes because of incorrect commandline definition argument
Summary: gcc crashes because of incorrect commandline definition argument
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 57122 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-05 10:24 UTC by michal.x
Modified: 2005-10-31 22:00 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-10-18 08:47:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:055 contract SHIPPED_LIVE Updated version of GCC 2.96-RH now available 2002-04-02 05:00:00 UTC

Description michal.x 2001-10-05 10:24:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
I had error in my makefile. There was created wrong definition commandline 
argument. Something like:
 gcc ... -D/tmp/file ... something.c

result:   SIGSEGV and core dump

Version-Release number of selected component (if applicable): 2.96 20000731


How reproducible:
Always

Steps to Reproduce:
1. write argument -D/somepath/somefile  into gcc commadline
2.
3.
	

Additional info:

Comment 1 Jakub Jelinek 2001-10-18 08:47:24 UTC
This was fixed with http://gcc.gnu.org/ml/gcc-patches/2001-05/msg01925.html,
this patch will make it into gcc-2.96-100.

Comment 2 Jakub Jelinek 2001-11-28 13:04:39 UTC
The fix is in 2.96-100 (and 101 too).

Comment 3 Jakub Jelinek 2001-12-18 13:05:29 UTC
*** Bug 57122 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2002-07-26 21:47:32 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-055.html



Note You need to log in before you can comment on or make changes to this bug.