Bug 54392 - xmlcatalog man page problems
xmlcatalog man page problems
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libxml2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 12:41 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-08 10:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Here is a better xmlcatalog.1. (3.78 KB, text/plain)
2001-10-05 12:42 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2001-10-05 12:41:58 EDT
Description of Problem:
The man page contains single quotes in disallowed places, it seems.  
Also, the formatting could be better.

Version-Release number of selected component (if applicable):
2.4.5-1
Comment 1 Tim Waugh 2001-10-05 12:42:28 EDT
Created attachment 33478 [details]
Here is a better xmlcatalog.1.
Comment 2 Daniel Veillard 2001-10-05 13:25:43 EDT
Argh ... it was contributed by John Fleck <jfleck@inkstain.net> (and
IIRC generated automatically from DocBook using XSLT), I will point
John at this he may have to fix his stylesheet.
How did you get the error ?

Daniel
Comment 3 Tim Waugh 2001-10-05 13:28:41 EDT
Ah, generated: I might have known. :-)

Okay, the original problem came from looking at the --add section.  Here's 
what it says:

       --add 'type' filename - Add an entry to catalog file file-
       name. type indicates the type of entry. Possible types are
       'public',  'system', 'rewriteSystem', is the original ref-
       erence to be replaced, and 'replace' is  the  URI  of  the
       replacement  entity  to  be used. The -add option will not
       overwrite filename, outputing to stdout, unless --noout is
       used.  The --add will always take three parameters even if
       some of the XML catalog constructs will have only a single
       argument.

There is obviously text missing at ...'rewriteSystem', is the original...

The .PP between each paragraph would be much better as a .TP, with the next 
line being the parameter stuff, and the next paragraph the description of it.
Comment 4 John Fleck 2001-10-05 13:44:41 EDT
I'll deal with this.
Comment 5 John Fleck 2001-10-05 22:41:29 EDT
Partial fix committed, dealing with the first part of the problem, the dropped
words in the "--add" bit.

The second part requires some more time with the stylesheet, as there are still
some problems with the output.
Comment 6 John Fleck 2001-10-06 18:32:56 EDT
Thanks to some stylesheet/DocBook advice from Martijn van Beers (LotR - what is
it the hip youngsters say - "shoutz to LotR"?) I believe this is fixed in CVS.
Could you take a look, Tim?
Comment 7 Tim Waugh 2001-10-07 17:39:17 EDT
It's still not quite right.  It looks like this:

.TP
\fB--shell\fR \fIfilename\fR
.PP
Run a shell allowing interactive queries on catalog file \fIfilename\fR.

The .PP line shouldn't be there; instead it should look like this:

.TP
\fB--shell\fR \fIfilename\fR
Run a shell allowing interactive queries on catalog file \fIfilename\fR.

Comment 8 John Fleck 2001-10-07 18:46:50 EDT
OK, another fix attempted. Could you give it another look, Tim?
Comment 9 Tim Waugh 2001-10-08 05:11:38 EDT
(1.3 still seems to be the latest revision, which is what I have commented on.)
Comment 10 John Fleck 2001-10-08 10:07:22 EDT
1.4 is in there. Are you perhaps using anoncvs, which takes time to update?

In any case, the section you mentioned above now reads:

.TP
\fB--shell\fR \fIfilename\fR

Run a shell allowing interactive queries on catalog file \fIfilename\fR.
Comment 11 Tim Waugh 2001-10-08 10:12:17 EDT
Yes, that looks better. (Although the blank line isn't needed either.)
Thanks.
Comment 12 Daniel Veillard 2001-10-21 04:57:19 EDT
Okay this seems solved in CVS, an I think is embedded in
libxslt 1.0.5 which should be in RawHide by now.

Daniel

Note You need to log in before you can comment on or make changes to this bug.