Bug 54396 - after long time, static develops in cs46xx driver
after long time, static develops in cs46xx driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 13:46 EDT by James Manning
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-08 11:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-10-05 13:46:44 EDT
Description of Problem:
after some seemingly random amount of time (usu. a couple of days), my 
constantly-running xmms (files from an NFS export mounted via autofs), which 
sounds great most of the time, develops a strong static sound.  The music is 
still the same, but now it sounds like it's coming in on a very weak AM 
station.  Stopping xmms, killing off xmms, then restarting xmms doesn't fix 
the problem.  With 2.4.7-10 (RH7.2 stock), a full reboot was required (I 
*think*) but what's 100% sure is that with 2.4.9-0.18 I removed cs46xx, 
ac97_codec, and soundcore then ran xmms.  Those modules loaded again 
and the music sounded normal again.

I only spend an hour or two at a time in Windows on this box, so it's hard to 
totally rule out hardware, but the modules reloading (and of course all the init 
that happens with that) clears up the problem, so I'm hoping it's some kind of 
state that the card gets in caused by a weird driver bug.  Machine is UP, 
single P3/800 with 384 MB of rambus rimm's and across the street over at 
2600 meridian if you need hands-on checking of anything.

Oct  3 12:30:38 jmm kernel: PCI: Found IRQ 10 for device 02:01.0
Oct  3 12:30:38 jmm kernel: Crystal 4280/46xx + AC97 Audio, version 
1.28.32, 05:20:57 Oct  3 2001
Oct  3 12:30:38 jmm kernel: cs46xx: Card found at 0xf4900000 and 
0xf4a00000, IRQ 10
Oct  3 12:30:38 jmm kernel: cs46xx: Unknown card (1013:4280) at 
0xf4900000/0xf4a00000, IRQ 10
Oct  3 12:30:38 jmm modprobe: modprobe: Can't locate module 
sound-service-0-0
Oct  3 12:30:38 jmm kernel: ac97_codec: AC97 Audio codec, id: 
0x4352:0x5903 (Cirrus Logic CS4297)
Oct  3 12:30:39 jmm automount[663]: attempting to mount entry 
/misc/ryan_mp3

02:01.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
        Subsystem: Cirrus Logic Crystal SoundFusion PCI Audio Accelerator
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium 
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1000ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at f4900000 (32-bit, non-prefetchable) [size=4K]
        Region 1: Memory at f4a00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk+ DSI+ D1+ D2+ AuxCurrent=0mA 
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 13 10 03 60 06 01 10 02 01 00 01 04 00 40 00 00
10: 00 00 90 f4 00 00 a0 f4 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 13 10 80 42
30: 00 00 00 00 40 00 00 00 00 00 00 00 0a 01 04 18
40: 01 00 2a 7e 00 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

How Reproducible:
Unfortunately, I have to wait for it to happen, I can't figure out how to force it to 
happen :(
Comment 1 James Manning 2001-10-05 14:04:35 EDT
FYI, it looks like some other sound problems (/dev/dsp being unavailable on 
occasion) are only happening with vmware running, so lemme confirm this can 
actually happen without vmware running (user *or* kernel space).  Sorry, forgot it 
was still running :(
Comment 2 Bill Nottingham 2001-10-08 11:17:24 EDT
No, this does happen without vmmware. I've seen it occasionally; reloading the
module always works.
Comment 3 James Manning 2002-05-17 12:49:08 EDT
it's been rock-solid for me the 7.3 betas and GM

Note You need to log in before you can comment on or make changes to this bug.