Bug 544006 - [abrt] crash detected in openbox-3.4.7.2-11.fc12
Summary: [abrt] crash detected in openbox-3.4.7.2-11.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openbox
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:163bd5fb
: 551710 568470 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-03 17:11 UTC by CharngXeL
Modified: 2010-02-26 11:10 UTC (History)
4 users (show)

Fixed In Version: 3.4.10-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-01 01:05:33 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.06 KB, text/plain)
2009-12-03 17:11 UTC, CharngXeL
no flags Details

Description CharngXeL 2009-12-03 17:11:06 UTC
abrt 1.0.0 detected a crash.

backtrace
-----
Summary: TB163bd5fb xdg-autostart:91:_findFile:TypeError: _isexecfile() takes exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/share/openbox/xdg-autostart", line 198, in <module>
    sys.exit(main())
  File "/usr/share/openbox/xdg-autostart", line 68, in main
    else: autofile.run(environments)
  File "/usr/share/openbox/xdg-autostart", line 162, in run
    if self._shouldRun(envs):
  File "/usr/share/openbox/xdg-autostart", line 139, in _shouldRun
    self._isexecfile):
  File "/usr/share/openbox/xdg-autostart", line 91, in _findFile
    if match_func(path): return path
TypeError: _isexecfile() takes exactly 1 argument (2 given)

Local variables in innermost frame:
path: /usr/libexec/dalston-power-applet
search: /usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/charngxel/bin
self: /etc/xdg/autostart/dalston-power-applet.desktop : Dalston power applet
match_func: <bound method AutostartFile._isexecfile of <__main__.AutostartFile instance at 0xb74346cc>>

cmdline: python /usr/share/openbox/xdg-autostart 
component: openbox
executable: /usr/share/openbox/xdg-autostart
kernel: 2.6.31.6-145.fc12.i686.PAE
package: openbox-3.4.7.2-11.fc12
uuid: 163bd5fb

Comment 1 CharngXeL 2009-12-03 17:11:10 UTC
Created attachment 375843 [details]
File: backtrace

Comment 2 Fedora Update System 2009-12-10 14:25:46 UTC
openbox-3.4.8-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openbox-3.4.8-1.fc12

Comment 3 Fedora Update System 2009-12-11 18:31:48 UTC
openbox-3.4.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13118

Comment 4 Miroslav Lichvar 2010-01-04 13:19:54 UTC
*** Bug 551710 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-01-08 11:11:03 UTC
openbox-3.4.10-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openbox-3.4.10-1.fc12

Comment 6 Fedora Update System 2010-01-08 19:55:40 UTC
openbox-3.4.10-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0318

Comment 7 Fedora Update System 2010-01-18 11:18:00 UTC
openbox-3.4.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openbox-3.4.10-2.fc12

Comment 8 Fedora Update System 2010-01-19 01:01:33 UTC
openbox-3.4.10-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0744

Comment 9 Fedora Update System 2010-01-22 11:42:01 UTC
openbox-3.4.10-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openbox-3.4.10-3.fc12

Comment 10 Fedora Update System 2010-01-22 22:30:33 UTC
openbox-3.4.10-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0881

Comment 11 Fedora Update System 2010-02-01 01:05:19 UTC
openbox-3.4.10-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Miroslav Lichvar 2010-02-26 11:10:48 UTC
*** Bug 568470 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.