Bug 54403 - browsable_dirs does not work on amd
browsable_dirs does not work on amd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: am-utils (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Aaron Brown
:
: 55599 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 18:10 EDT by Mike Gahagan
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version: 6.0.9-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 03:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2001-10-05 18:10:46 EDT
Description of Problem:



Browsable directories do not work



Version-Release number of selected component (if applicable):



am-utils 6.0.6-3



How Reproducible:



always



Steps to Reproduce:

1. use config files below

2. start amd

3. note that /nfs share will not show available directories



Actual Results:



directories will mount when cd'd to, but do not show up when doing an 'ls'



Expected Results:



Should be able to see map directories symlinked to proper place



Additional Information:

	

this confiuration works when the 7.1 version of am-utils is installed. setting browseable_dirs to full or on has no effect







amd.conf -



#

# amd default config file

#

# check amd.conf(5) man page for details about options in this file

#



# GLOBAL OPTIONS SECTION

[ global ]

normalize_hostnames =   no

print_pid =             yes

pid_file =              /var/run/amd.pid

restart_mounts =        yes

auto_dir =              /.automount

#log_file =             /var/log/amd

log_file =              syslog

log_options =           all

#debug_options =        all

plock =                 no

selectors_on_default =  yes

print_version =         no

# set map_type to "nis" for NIS maps, or comment it out to search for all

# types

map_search_path =           /etc

browsable_dirs =        full

show_statfs_entries =   no

fully_qualified_hosts = no

cache_duration =        300



# DEFINE AN AMD MOUNT POINT

[ /net ]

map_name =              amd.net

map_type =              file



[ /nfs ]

map_name =              amd.nfs

map_type =              file

type =              file



-- EOF --



amd.nfs -

# amd.nfs

/defaults type:=nfs;opts:=nosuid,nodev,rsize=8192,wsize=8192,ro,intr

test       host==server.domain.com;fs:=/mnt/test; \

        rhost:=server.domain.com;rfs:=/mnt/test
Comment 1 Peter Vrabec 2005-09-27 03:55:36 EDT
it works with current release

# amd.nfs
/defaults type:=nfs;opts:=nosuid,nodev,rsize=8192,wsize=8192,ro,intr
test      rhost:=vm-nfs1;rfs:=/mnt/stuff

$ ll
total 1
lrwxrwxrwx  1 root root 29 Sep 27 09:55 test -> /.automount/vm-nfs1/mnt/stuff

see:
http://www.am-utils.org/docs/am-utils/am-utils_10.html#SEC97
Comment 2 Peter Vrabec 2005-09-27 03:57:48 EDT
*** Bug 55599 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.