Bug 544125 - [abrt] crash detected - Meter::GetMaxPeak (this=0x0) at widgets/Meter.cpp:727
Summary: [abrt] crash detected - Meter::GetMaxPeak (this=0x0) at widgets/Meter.cpp:727
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ca13cbf87f747e06792448a69de...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-03 23:22 UTC by Uli Köhler
Modified: 2009-12-11 18:36 UTC (History)
3 users (show)

Fixed In Version: 1.3.9-0.5.beta.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-11 18:36:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (20.05 KB, text/plain)
2009-12-03 23:22 UTC, Uli Köhler
no flags Details

Description Uli Köhler 2009-12-03 23:22:32 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: audacity
component: audacity
executable: /usr/bin/audacity
kernel: 2.6.30.9-90.fc11.x86_64
package: audacity-1.3.9-0.4.beta.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Uli Köhler 2009-12-03 23:22:34 UTC
Created attachment 375956 [details]
File: backtrace

Comment 2 Michael Schwendt 2009-12-04 14:03:28 UTC
Since you didn't include any steps on how to reproduce it, I assume you enabled "Sound Activated Recording". There is a race-condition in that feature. It causes start of recording to run into an uninitialised value (= the input meter that is set too late). I've added a work-around and will forward this report upstream.

Comment 3 Fedora Update System 2009-12-04 14:30:24 UTC
audacity-1.3.9-0.5.beta.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/audacity-1.3.9-0.5.beta.fc12

Comment 4 Fedora Update System 2009-12-07 07:33:14 UTC
audacity-1.3.9-0.5.beta.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacity'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12842

Comment 5 Fedora Update System 2009-12-11 18:36:45 UTC
audacity-1.3.9-0.5.beta.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.