Bug 54416 - gif2png fails with a libpng fatal error condition
Summary: gif2png fails with a libpng fatal error condition
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libpng (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-06 18:45 UTC by Landon Curt Noll
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-06 18:45:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Landon Curt Noll 2001-10-06 18:45:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.2.19-7.0.8 i686)

Description of problem:
The gif2png tool fails with the following error condition:

libpng error: Application uses deprecated png_write_init() and must be
recompiled.
gif2png:  libpng returns fatal error condition


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gif2png -O efflogo.gif
2.
3.
	

Actual Results:  libpng error: Application uses deprecated png_write_init()
and must be recompiled.
gif2png:  libpng returns fatal error condition


Expected Results:  creates efflogo.png

Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-10-23 16:54:43 UTC
That's gif2png's fault, not libpng's (it's using an obsolete function that has 
been deprecated since libpng 0.9).

gif2png is not a part of libpng, and not shipped with Red Hat Linux, so 
there's nothing we can do about it.

Recommendations:
1) Check wherever you got gif2png - maybe they've released a new version that 
fixes this problem.

2) Use ImageMagick's convert tool instead (syntax: convert filename.gif 
filename.png). It is included in Red Hat Linux, so you don't need a new 
download.





Note You need to log in before you can comment on or make changes to this bug.