Bug 54421 - All games in ace-rhcn-1.1-13 crash on F1.
Summary: All games in ace-rhcn-1.1-13 crash on F1.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ace-rhcn   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-07 05:49 UTC by Pavel Roskin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Roskin 2001-10-07 05:49:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20011004

Description of problem:
Pressing F1 in all games causes them to crash instead of displaying the help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run solitaire
2.Press F1
	

Actual Results:  $ solitaire
can't find image `xemboss.gif'  
Segmentation fault (core dumped)


Expected Results:  Help or at least a message that help is missing. At very
least nothing, but not a coredump.

Additional info:

It's the version ace-rhcn-1.1-13 from the updates. The error message is
probably wrong - it's not xemboss.gif that is missing. Here's the end of
the strace output:

open("solitaire.html", O_RDONLY)        = -1 ENOENT (No such file or directory)
brk(0x8081000)                          = 0x8081000
fstat64(1, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 2), ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40016000
write(1, "can\'t find image `xemboss.gif\'\n", 31) = 31
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 Bernhard Rosenkraenzer 2002-01-29 11:19:38 UTC
Since powertools was discontinued, the official "fix" is the removal of the 
package. 
Sorry...


Note You need to log in before you can comment on or make changes to this bug.