Bug 54430 - Patch to build with python-2.2
Summary: Patch to build with python-2.2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-python   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-08 07:40 UTC by Need Real Name
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-08 07:42:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for configure and Makefile.in (1.95 KB, patch)
2001-10-08 07:42 UTC, Need Real Name
no flags Details | Diff

Description Need Real Name 2001-10-08 07:40:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010929

Description of problem:
rpm-4.0.3-1.04 does not build with python-2.2, since python-1.5
is built into both the .spec file and the configure/Makefile.in.

Version-Release number of selected component (if applicable):
rpm-4.0.3-1.04.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Rebuild with python-2.2-0.3a3 installed
2.
3.
	

Additional info:

cat /tmp/rpm-4.0.3-patched/rpm.spec.patch
--- /usr/src/redhat/SPECS/rpm.spec      Thu Sep 13 22:43:41 2001
+++ /usr/src/redhat/SPECS/rpm.spec.new  Fri Oct  5 07:22:45 2001
@@ -19,11 +19,12 @@
 %define version 4.0.3
 Version: %{version}
 %{expand: %%define rpm_version %{version}}
-Release: 1.04
+Release: 1.05
 Group: System Environment/Base
 Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/rpm-%{rpm_version}.tar.gz
 Copyright: GPL
 Conflicts: patch < 2.5
+Patch0: rpm-4.0.3-pyhton.patch
 %ifos linux
 Prereq: gawk fileutils textutils mktemp shadow-utils
 %endif
@@ -150,6 +151,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 
@@ -443,8 +445,8 @@
 %if %{with_python_subpackage}
 %files python
 %defattr(-,root,root)
-%{__prefix}/lib/python1.5/site-packages/rpmmodule.so
-%{__prefix}/lib/python1.5/site-packages/poptmodule.so
+%{__prefix}/lib/python2.2/site-packages/rpmmodule.so
+%{__prefix}/lib/python2.2/site-packages/poptmodule.so
 %endif
 
 %if %{with_perl_subpackage}
@@ -505,6 +507,9 @@
 %{__prefix}/include/popt.h
 
 %changelog
+* Fri Oct  5 2001 Svante Signell  <svante.signell@telia.com.com> 4.0.3-1.05
+- fix: enable build with python2.2
+
 * Thu Sep 13 2001 Jeff Johnson <jbj@redhat.com>
 - fix: initialize "verify" transaction stepName with -vv (#53582).
 - fix: ftp remote globs broken (#46892)

Patch file will be attached. Note that the patch does not involve
Makefile.am, so additional changes are needed when using automake.

Comment 1 Need Real Name 2001-10-08 07:42:51 UTC
Created attachment 33561 [details]
patch for configure and Makefile.in

Comment 2 Jeff Johnson 2001-12-09 18:25:54 UTC
Essentially your patch is now in rpm-4.0.4. What's still needed
is autodetection of both python-1.5.2 and/or python-2.2.


Note You need to log in before you can comment on or make changes to this bug.