Bug 54434 - Failed to load module "pcidata" (module does not exist, 0)
Failed to load module "pcidata" (module does not exist, 0)
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-10-08 07:59 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-09 17:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/XFree86.0.log (2.19 KB, text/plain)
2001-10-08 08:02 EDT, Need Real Name
no flags Details
/etc/X11/XF86Config-4 (3.67 KB, text/plain)
2001-10-08 08:03 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-08 07:59:09 EDT
Description of Problem:

startx failed after installation
(WW) Warning, couldn't open module pcidata
(EE) Failed to load module "pcidata" (module does not exist, 0)

Version-Release number of selected component (if applicable):

RedHat Linux 7.1 Professional Server
XFree86 4.0.3

How Reproducible:

After startx

Steps to Reproduce:

Actual Results:

Expected Results:

Additional Information:
Comment 1 Need Real Name 2001-10-08 08:02:22 EDT
Created attachment 33562 [details]
Comment 2 Need Real Name 2001-10-08 08:03:12 EDT
Created attachment 33563 [details]
Comment 3 Mike A. Harris 2001-10-09 08:16:09 EDT
Please run "Xconfigurator" and reconfigure your card.  Does that get it
working?  If not, please reattach the new config and log files.

Comment 4 Need Real Name 2001-10-09 16:30:17 EDT
I run Xconfigurator and run into the same problem. 
My opinion is, that pcidata could not be found, because libpcidata.a is not 
installed in /usr/X11R6/lib/modules.
I rerun the installation and installed everything, no changes.
Comment 5 Need Real Name 2001-10-09 17:13:31 EDT
I have installed rh71 from CD under vmware. pcidata is installed. Is their a 
difference when installing from DVD, where the problem occured ?
Comment 6 Need Real Name 2001-10-09 17:55:20 EDT
After installing system from CD-ROM, system works fine so far.
This bug could be closed
Comment 7 Mike A. Harris 2001-10-09 23:03:45 EDT
Yes, the DVD's were flawed.  You can obtain replacements by contacting
technical support for your region.

Please note for future reference that although we hope Red Hat Linux
works inside a VMware virtual machine, we do not test such installations,
nor do we support installation into a VMware virtual machine.  We also
do not support bugs that occur while VMware software is running, or has
been loaded into memory.  Therefore, before reporting any bugs in XFree86,
you need to reproduce it without VMware first.  This is very important.

At any rate, looks like you have got things going now.
Comment 8 Need Real Name 2001-10-10 03:58:25 EDT
For the better understanding, I installed rh71 only for testing on a different 
machine, before doing the native installation on true true hardware from DVD. I 
do know that vmware is not your business is is not supported by RedHat.
The error I have reported did not occur under vmware. This was a different 
installation on another machine. I did this to assist you in gathering 
information to get this bug solved.

Note You need to log in before you can comment on or make changes to this bug.