Bug 54435 - RP3 falls back to bad default font
RP3 falls back to bad default font
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-08 08:38 EDT by Manfred Hollstein
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2001-10-08 08:38:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
The current version of RP3 in the latest 7.2 beta relies on the
font "-schumacher-clean-medium-r-normal-*-*-80-*-*-c-*-iso8859-1"
being existant; however, this font is called differently in 7.2beta,
it's something like iso646.1991 instead of the expected iso8859-1,
therefore rp3 decides to use the fallback font "fixed" instead, which
is simply TOO BIG to be used inside an applet.

Version-Release number of selected component (if applicable):
rp3-1.1.10-3

How reproducible:
Always

Steps to Reproduce:
1.Start rp3 as an applect
2.Watch the numbers shown in the applet
3.They are TOO BIG
	

Actual Results:  The applet looks ugly; most information is lost due to the
numbers
being too big.

Expected Results:  A similar layout as has been available as part of RHL 7.1.

Additional info:

Apply this patch to the sources of the rp3 package:

diff -rup rp3-1.1.10.orig/utils/gtknetmon.c rp3-1.1.10/utils/gtknetmon.c
--- rp3-1.1.10.orig/utils/gtknetmon.c   Tue Feb 27 00:09:43 2001
+++ rp3-1.1.10/utils/gtknetmon.c        Mon Oct  8 14:12:41 2001
@@ -477,7 +477,7 @@ gtk_netmon_realize        (GtkWidget    
 
   /* Load fonts */
 
-  netmon->small_font =
gdk_font_load("-schumacher-clean-medium-r-normal-*-*-80-*-*-c-*-iso8859-1");
+  netmon->small_font =
gdk_font_load("-schumacher-clean-medium-r-normal-*-*-80-*-*-c-*-*");
 
   if (netmon->small_font == NULL)
     {
Comment 1 Manfred Hollstein 2001-10-25 03:50:34 EDT
I just selected the correct version of Red Hat Linux in which this fault occurs,
which is 7.2.
Comment 2 Manfred Hollstein 2002-05-05 04:48:02 EDT
This report can be closed as it is fixed in rp3 which comes with RHL 7.3. See
also <https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=62851>
Comment 3 Bill Nottingham 2006-08-07 15:44:54 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 13:04:33 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.