Bug 54453 - Spurious pestering from logwatch
Summary: Spurious pestering from logwatch
Status: CLOSED DUPLICATE of bug 51882
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-08 17:34 UTC by Michal Jaegermann
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 18:57:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-10-08 17:34:44 UTC
Description of Problem:

Logwatch insists on sending messages indicating a normal operation
of sshd like "Accepted password", "Server listening" or "Starting sshd:
 succeeded".  Also for sendmail stuff like "695 bytes transferred
1 messages sent".  On a bit more busy server this will get very fast
annoying beyond any point of usability.

Even if there is nothing to report then 'logwatch' insists on sticking
into mail messages like that:

 ################## LogWatch 2.1.1 Begin #####################


 ###################### LogWatch End #########################

Attempts to find out how to adjust filters immediately run into
that problem that what is passing for a documentation (manpage
and a contents of /usr/share/doc/logwatch-2.1.1 directory) is very
sketchy, unclear, and does not seem to be that close to reality.
An option to study Perl code of /usr/bin/logwatch to gain an
understanding what is really going on is not very appealing.

To provide more entertainment value files in /etc/log.d/conf/services
have, for example, lines like that:

# Only give lines pertaining to the sshd service...
*OnlyService = kernel

in 'kernel' and

# Only give lines pertaining to the mountd service...
*OnlyService = sshd2

in 'sshd2'.  But what a line

*RemoveHeaders =

is really doing there one can only try to guess.

For a software outwardly related to security this does not seem
like a very good and convincing show.

Comment 1 Elliot Lee 2002-01-04 18:57:41 UTC
Aka "logwatch sucks"

I asked the author for a new release recently. We'll see what happens.

Comment 2 Elliot Lee 2002-04-15 14:37:22 UTC

*** This bug has been marked as a duplicate of 51882 ***


Note You need to log in before you can comment on or make changes to this bug.