Bug 54459 - (SOUND I810_AUDIO)i810_audio unable to init intel 815 onboard sound
(SOUND I810_AUDIO)i810_audio unable to init intel 815 onboard sound
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-09 01:34 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 14:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-09 01:34:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.0 i586)

Description of problem:
I just upgraded to an intel 815 motherboard that has AC97 onboard sound
(AD1885), and have had several problems.
First, the chip isn't identified correctly.  /var/log/messages produces:
Intel 810 + AC97 Audio, version 0.03, 02:23:58 Oct  7 2001
PCI: Found IRQ 11 for device 00:1f.5
PCI: Sharing IRQ 11 with 00:1f.3
PCI: Setting latency timer of device 00:1f.5 to 64
i810: Intel ICH2 found at IO 0xef00 and 0xe800, IRQ 11
ac97_codec: AC97 Audio codec, id: 0x4144:0x5360 (Unknown)

In the kernel mailing list archives I found a reference to this:
http://www.uwsg.iu.edu/hypermail/linux/kernel/0103.1/0394.html 
So I fixed that and recompiled.  Now the chip is detected correctly, but
seems to not work.  The driver loads and says:
Oct  8 12:12:28 spider kernel: i810: Intel ICH2 found at IO 0xef00 and
0xe800, IRQ 11
Oct  8 12:12:28 spider kernel: ac97_codec: AC97 Audio codec, id:
0x4144:0x5360 (Analog Devices AD1885)
Oct  8 12:12:28 spider kernel: i810_audio: setting clocking to 7032

but it simply doesn't work.  I tried setting the clocking option in
modules.conf to a more reasonable value (48730) but to no avail.
At this point, the mixer works - I can play cds and adjust the volume.

Searching further, I found some other reference to the alsa drivers working
for other people who've had similar problems with this driver and board.  I
compiled and installed alsa but could not produce sound. In fact at this
point the mixer no longer seems to work - no cd playback anymore.  I did
insert the oss compatibility modules.

But then, unload the alsa modules, load in i810_audio and shazam, sound.

This appears to be somewhat reproducible on this motherboard - after a
reboot no sound.  Unload i810_audio and ac97_codec, load in the alsa
modules unload alsa, reload i810_audio and ac97_codec and sound *usually*
works.

Additional info:

A couple last bits of strangeness - mplayer (the movie player) seems
unhappy with the sound drivers.  If I tell it to produce no sound, video is
fine.  If I let it play the audio track, the video doesn't show up (but the
sound plays).  It used to work fine...

Last bit of strangeness.  I have a second computer with the same
motherboard.  It was a fresh install with RedHat 7.1.  Sound on that board
worked, but was flakey.  It would work, then randomly stop working - unload
modules, reload a few times and it would start to work again.  Then I
upgraded the kernel to 2.4.6-2 to solve a video problem and the sound has
worked perfectly ever since.
Comment 1 Arjan van de Ven 2001-10-09 04:10:39 EDT
One question: which kernel version has the problem ?
Comment 2 Need Real Name 2001-10-09 11:20:45 EDT
Sorry: 2.4.7-2
Comment 3 Alan Cox 2003-06-10 14:17:37 EDT
Should be handled by errata kernels nowdays.

Note You need to log in before you can comment on or make changes to this bug.