Bug 5446 - Delete & backspace
Delete & backspace
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
6.0
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-29 18:50 EDT by Bryce Nesbitt
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-30 13:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 1999-09-29 18:50:35 EDT
After all these years, it is unfortunate that something as
simple as backspace and delete is still messed up.  I view
it as the job of the packager to set all the flags and
settings* to fix this, rathern than relying on dozens of
howtows and individual user efforts.

Could you do it once, and save us all the trouble?

        -Bryce

* Recently I stumbled with a beginner having trouble, until
I found "pico -d".
Comment 1 Preston Brown 1999-09-30 13:31:59 EDT
out of the box, backspace and delete work correctly on the console and
in X in 6.0 and later.  What seems to be the problem?

------- Additional Comments From   09/30/99 13:58 -------
I've been with RedHat a while.  A new upgrade always involves refixing
delete & backspace in several places.  Try the editor "pico".  Notice
that backspace and delete do the same thing.  Delete should pull
characters from the right, backspace overwrite to the left.  "pico -d"
fixes it.

bash, as configured on 6.0 has the same problem.  ftp is screwed up
(backspace results in "^H" on the screen, delete works like backspace
should).  telnet same thing.

This is RedHat 6.0 out of the box.  We're all using the same PC
keyboards, this should work right out the box!!

Note You need to log in before you can comment on or make changes to this bug.