Bug 54496 - XML-style empty tag problems
Summary: XML-style empty tag problems
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openjade   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-10 08:48 UTC by Tim Waugh
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-19 13:05:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2001-10-10 08:48:03 UTC
Description of Problem:
Openjade has trouble with <empty/>-form tags.

Version-Release number of selected component (if applicable):
openjade-1.3-18

How Reproducible:
100%

Steps to Reproduce:
1. Run 'sgmlnorm -c /etc/sgml/catalog file.sgml' on this file.sgml:

<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook V3.1//EN"[]>
<article>
  <title>Demonstration of openjade bug</title>

  <section id="demo">
    <title>Bug demonstration</title>

    <para>A cross-reference to this section comes out as
     <quote><xref linkend="demo"/></quote>.</para>
  </section>
</article>


Actual Results:
<ARTICLE>
<TITLE>Demonstration of openjade bug</TITLE>
<SECTION ID="DEMO">
<TITLE>Bug demonstration</TITLE>
<PARA>A cross-reference to this section comes out as
     <QUOTE><XREF LINKEND="DEMO">&#62;</QUOTE>.</PARA>
</SECTION>
</ARTICLE>


Expected Results:
<ARTICLE>
<TITLE>Demonstration of openjade bug</TITLE>
<SECTION ID="DEMO">
<TITLE>Bug demonstration</TITLE>
<PARA>A cross-reference to this section comes out as
     <QUOTE><XREF LINKEND="DEMO"></QUOTE>.</PARA>
</SECTION>
</ARTICLE>


Additional Information:
I think that '/>' is an XML thing, but openjade ought to handle it in SGML for 
interoperability.

Comment 2 Tim Waugh 2001-10-20 14:03:26 UTC
Prevailing opinion seems to be that this is not a bug, and is in fact expected 
behaviour: <tab/> is not valid SGML.



Note You need to log in before you can comment on or make changes to this bug.