Bug 54514 - Changes in config file not reflected after loader install / reboot (same 'old' options)
Changes in config file not reflected after loader install / reboot (same 'old...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-10 16:02 EDT by Didier Richard
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-10 16:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file (273 bytes, text/plain)
2001-10-10 16:03 EDT, Didier Richard
no flags Details

  None (edit)
Description Didier Richard 2001-10-10 16:02:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
I tried to integrate the (new) kernel 2.4.11 in my boot options. I changed
/etc/lilo.conf and ran "lilo -v" to update the loader sector. When I
rebooted, the old boot options where still there, no option to try my new
kernel...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.I had a RH 6.2 system, then upgraded to RH 7.1
2.Updated lilo.conf to get kernel 2.4.10 and keep RH7.1's 2.4.2, that one
was OK
3.Tried to get a new entry for kernel 2.4.11. No way
	

Actual Results:  Same options for boot showed up

Expected Results:  New option should have shown up

Additional info:

When executing "lilo -v", here what it shows :
=====================================================================
# lilo -v
LILO version 21.4-4, Copyright (C) 1992-1998 Werner Almesberger
'lba32' extensions Copyright (C) 1999,2000 John Coffman

Reading boot sector from /dev/hda1
Merging with /boot/boot.b
Boot image: /boot/vmlinuz-2.4.11
Added linux *
Boot image: /boot/vmlinuz-2.4.2-2
Mapping RAM disk /boot/initrd-2.4.2-2.img
Added RH7
/boot/boot.0301 exists - no backup copy made.
Writing boot sector.
=====================================================================
Nothing special there (I use /dev/hda1 as the boot/root partition for
special cases lilo does not know (yet) how to handle.

Here is my "/etc/lilo.conf" :
=====================================================================
# cat lilo.conf
default=linux
boot=/dev/hda1
prompt
timeout=100
install=/boot/boot.b
map=/boot/map
image=/boot/vmlinuz-2.4.11
        label=linux
        read-only
        root=/dev/hda1
        append="S"
image=/boot/vmlinuz-2.4.2-2
        label=RH7
        initrd=/boot/initrd-2.4.2-2.img
        read-only
        root=/dev/hda1
        append="S"
=====================================================================
Nothing special here either. It worked when I installed kernel 2.4.10 after
upgrading to RH 7.1. But from now on, no way to get to 2.4.11.
Several tries to put change lines, comment-out some, every time re-install
boot sector and cold / warm reboots...Still the old options.
What's even funnier is that "lilo -q" gives the options which are indicated
in the config file, which are actually not the ones that are available on boot.
Still, "lilo -t -v" does not give a better clue on 'why can I not change
this _any more_ ?"
Comment 1 Didier Richard 2001-10-10 16:03:55 EDT
Created attachment 33803 [details]
Config file
Comment 2 Doug Ledford 2001-10-10 17:49:14 EDT
You forgot to uninstall lilo from the master boot record of your hard drive when
you switched the boot device from /dev/hda to /dev/hda1.  If you have a DOS boot
floppy (or a bootable Windows CD-ROM) or have DOS or Windows installed on
another partition, you can run the DOS fdisk command with the switch /mbr to
install a normal master boot record instead of the lilo master boot record your
hard disk currently has.  The other option is to switch the boot= device from
/dev/hda1 back to /dev/hda.

Note You need to log in before you can comment on or make changes to this bug.