This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 54522 - XFree86 calculates display size incorrectly with Xinerama.
XFree86 calculates display size incorrectly with Xinerama.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-11 07:07 EDT by David Woodhouse
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-19 03:43:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch #4986 (1.02 KB, patch)
2001-12-19 03:43 EST, David Woodhouse
no flags Details | Diff

  None (edit)
Description David Woodhouse 2001-10-11 07:07:37 EDT
XFree86 incorrectly calculates the display size. When taking into account
two 40x30 cm monitors side by side, it seems to conclude that the total
viewing area is only 40x30, hence causing xdpyinfo to report an incorrect
aspect ratio:

screen #0:
  dimensions:    3520x1440 pixels (403x302 millimeters)
  resolution:    222x121 dots per inch


Applications have started to use this information. Mozilla seems to get
very confused, and openoffice displays documents twice as wide as they
should be. There doesn't seem to be any way to override this - even a dpi
value which is specified on the XFree86 commandline gets 'corrected' by the
Xinerama code.
Comment 1 Mike A. Harris 2001-10-15 02:39:43 EDT
This has been fixed aparently in XFree86 CVS, and will appear in the
4.2.0 release.
Comment 2 David Woodhouse 2001-11-04 05:03:38 EST
Filing against 7.2 to avoid duplicates.
Comment 3 David Woodhouse 2001-12-19 03:42:28 EST
This seems to be fixed by patch #4986.
http://www.xfree86.org/devel/archives/patch/2001-Oct/0019.shtml

Please could you drop it into your 4.1 build tree too?
Comment 4 David Woodhouse 2001-12-19 03:43:39 EST
Created attachment 41008 [details]
patch #4986
Comment 5 Mike A. Harris 2002-01-25 03:05:59 EST
XFree86 4.2.0 in rawhide now contains this fix

Note You need to log in before you can comment on or make changes to this bug.