Bug 545685 - [abrt] crash detected in evince-2.28.1-5.fc12
[abrt] crash detected in evince-2.28.1-5.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:bd2436c31e1336a4c7eec9c058c...
:
: 545686 553410 560253 567501 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 00:12 EST by Michael
Modified: 2010-05-07 13:24 EDT (History)
8 users (show)

See Also:
Fixed In Version: evince-2.28.2-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 13:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.12 KB, text/plain)
2009-12-09 00:12 EST, Michael
no flags Details
patch checking mapping for NULL (635 bytes, patch)
2010-04-19 10:12 EDT, Marek Kašík
no flags Details | Diff

  None (edit)
Description Michael 2009-12-09 00:12:58 EST
abrt detected a crash.

Attached file: backtrace
cmdline: evince file:///tmp/book-2009-11-1.pdf
component: evince
executable: /usr/bin/evince
kernel: 2.6.31.5-127.fc12.x86_64
package: evince-2.28.1-5.fc12
rating: 3
reason: Process was terminated by signal 11
Comment 1 Michael 2009-12-09 00:12:59 EST
Created attachment 377100 [details]
File: backtrace
Comment 3 Karel Klíč 2010-02-24 12:03:01 EST
*** Bug 553410 has been marked as a duplicate of this bug. ***
Comment 4 Martin Jürgens 2010-03-21 19:52:26 EDT

How to reproduce
-----
1. open http://www.hetzner.de/pdf/Uebertragung.pdf
2. do something
3. scroll


Comment
-----
dont know how exactly it crashed
Comment 5 Marek Kašík 2010-03-25 06:12:20 EDT
*** Bug 545686 has been marked as a duplicate of this bug. ***
Comment 6 Marek Kašík 2010-03-25 06:12:27 EDT
*** Bug 560253 has been marked as a duplicate of this bug. ***
Comment 7 Marek Kašík 2010-03-25 06:14:03 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=567501 is another duplicate of this bug probably.

Marek
Comment 8 Doug Hutcheson 2010-03-28 23:54:24 EDT

How to reproduce
-----
1. Reading a PDF which had just been downloaded


Comment
-----
Downloaded a PDF from a web site and was reading it when it closed without warning.
Comment 9 Brian Lane 2010-04-06 16:53:11 EDT

How to reproduce
-----
1. Open editable pdf
2. click on a editable field
3. scroll to end of document


Comment
-----
Happens every time with this document.
Comment 10 Warren Lewis 2010-04-17 19:59:38 EDT

How to reproduce
-----
Unknown, random failure with reading PDF document.
Comment 11 Warren Lewis 2010-04-17 20:02:15 EDT
This was a PDF downloaded with Firefox and opened directly, not saved.
Comment 12 Marek Kašík 2010-04-19 10:12:40 EDT
Created attachment 407600 [details]
patch checking mapping for NULL

Hi,

thank you for your informations. This bug is a downstream version of upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=602405.
The patch from upstream is really huge and depends on another patches. So, I won't commit it into F12. I've created a small patch which only checks the problematic structure for NULL. Evince doesn't crash with the patch applied.

Regards

Marek

Btw, the upstream patch is in Fedora 13 already (as part of stable release of evince)
Comment 13 Fedora Update System 2010-04-19 10:55:47 EDT
evince-2.28.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/evince-2.28.2-2.fc12
Comment 14 Marek Kašík 2010-04-19 10:59:44 EDT
*** Bug 567501 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2010-04-20 22:18:08 EDT
evince-2.28.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evince'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/evince-2.28.2-2.fc12
Comment 16 Fedora Update System 2010-05-07 13:24:24 EDT
evince-2.28.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.