Bug 54587 - raidtools-0.90-23 dynamic links to popt libs on /usr partition
Summary: raidtools-0.90-23 dynamic links to popt libs on /usr partition
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: raidtools   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 55075 55198 55304 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-13 04:13 UTC by edwinh
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-13 04:13:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:143 normal SHIPPED_LIVE New raidtools packages available to fix dependency on /usr 2001-10-29 05:00:00 UTC

Description edwinh 2001-10-13 04:13:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011012

(From rawhide 20011003)

Description of problem:
raidtools-0.90-23 is dynamically linked with popt (recent change).  This is
a problem since popt is in /usr, which may not be the root partition.

ldd /sbin/raidstart 
	libpopt.so.0 => /usr/lib/libpopt.so.0 (0x4002b000)
	libc.so.6 => /lib/i686/libc.so.6 (0x40032000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

raid setup in rc.sysinit will fail to start up raid when only 
root is mounted and you have a separate /usr...


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use raidtools-0.90-23
2. have a separate /usr partition
3. have software raid setup
	

Actual Results:  breakage during rc.sysinit when raidstart etc runs

Expected Results:  static link libpopt if we don't want to move it to /lib?


Additional info:

Comment 1 Bill Nottingham 2001-10-15 14:28:54 UTC
Fixed in 0.90-24.

Comment 2 Bill Nottingham 2001-10-29 16:46:09 UTC
*** Bug 55198 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2001-10-29 16:46:20 UTC
*** Bug 55304 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2001-10-29 19:07:01 UTC
*** Bug 55075 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.