This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 546478 - [abrt] crash detected in compiz-0.8.2-19.fc12 #0 in thumbPaintThumb () at thumbnail.c:669 in thumbnail.c
[abrt] crash detected in compiz-0.8.2-19.fc12 #0 in thumbPaintThumb () at t...
Status: CLOSED DUPLICATE of bug 539394
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
abrt_hash:a2147be40e64e00ad2bde3ec8da...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 18:19 EST by Edward Rudd
Modified: 2009-12-21 12:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-21 12:41:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (16.00 KB, text/plain)
2009-12-10 18:19 EST, Edward Rudd
no flags Details
Compiz configuration file (44 bytes, text/plain)
2009-12-11 13:05 EST, Edward Rudd
no flags Details

  None (edit)
Description Edward Rudd 2009-12-10 18:19:36 EST
abrt 1.0.0 detected a crash.

Comment: Authenticating to install a local package via gpk-install-local-file
Attached file: backtrace
cmdline: compiz --replace --sm-disable --ignore-desktop-hints ccp
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.6-145.fc12.i686.PAE
package: compiz-0.8.2-19.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Edward Rudd 2009-12-10 18:19:38 EST
Created attachment 377619 [details]
File: backtrace
Comment 2 Hamidou Dia 2009-12-11 04:54:05 EST
Core was generated by `compiz --replace --sm-disable --ignore-desktop-hints ccp'.
Program terminated with signal 11, Segmentation fault.
#0  0x00aa467c in thumbPaintThumb (s=0x8d18c78, t=<value optimized out>, 
    transform=0xbfe7c980) at thumbnail.c:669
	in thumbnail.c

Thread 1 (Thread 5182):
#0  0x00aa467c in thumbPaintThumb (s=0x8d18c78, t=<value optimized out>, 
    transform=0xbfe7c980) at thumbnail.c:669
        oldAddWindowGeometry = 0x8d4e828
        w = 0x9a83f48
        wx = 1121
        wy = 964
        width = -1.55791786e-05
        height = 114
        sAttrib = {opacity = 0, brightness = 0, saturation = 0, xScale = 0, 
          yScale = 0, xTranslate = 0, yTranslate = 0}
#1  0x00aa5841 in thumbPaintOutput (s=0x8d18c78, sAttrib=0x80829a0, transform=
    0x8078560, region=0x8bb3690, output=0x8d95ae0, mask=1) at thumbnail.c:965
        sTransform = {m = {0.000624999986, 0, 0, 0, -0, -0.000833333354, -0, 
    -0, 0, 0, 1, 0, -0.5, 0.5, -0.866025388, 1}}
        status = 1
        newMask = <value optimized out>
        ts = 0x92cc078
#2  0x00bc6ebb in cubePaintOutput (s=<value optimized out>, 
    sAttrib=<value optimized out>, transform=<value optimized out>, 
    region=<value optimized out>, output=<value optimized out>, 
    mask=<value optimized out>) at cube.c:845
        status = <value optimized out>


---------------------------------------------------------


Hi Edward,

Thanks for the report.

Could you just let us know if you remember how this crash occurred and paste the info in this ticket?

Many thanks in advance.

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Edward Rudd 2009-12-11 13:05:23 EST
I have not yet been able to nail down a cause for the crash yet.

It happens seemingly randomly. This case it was me typing the password into the actual policy kit prompt.

Other times I'll just move a window and compiz will crash and restart (I'm running the fusion-icon to ensure it restarts/make it easy for me to reload it)
Comment 4 Edward Rudd 2009-12-11 13:05:53 EST
Created attachment 377775 [details]
Compiz configuration file
Comment 5 Matěj Cepl 2009-12-21 12:41:37 EST

*** This bug has been marked as a duplicate of bug 539394 ***

Note You need to log in before you can comment on or make changes to this bug.