This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 546564 - dnsmasq is started even if no service configured
dnsmasq is started even if no service configured
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 03:54 EST by Marian Ganisin
Modified: 2009-12-11 05:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-11 05:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2009-12-11 03:54:00 EST
Description of problem:
libvirt is starting dnsmasq even if there isn't any related record in configuration. It is regression against libvirt in F11, which allowed me to run custom dnsmasq service (now dnsmasq started by libvirt opens important ports and blocks other instances).

Version-Release number of selected component (if applicable):
libvirt-0.7.1-15.fc12.x86_64

Expected results:
libvirt doesn't start dnsmasq if not explicitly requested in configuration (as previous version did it). Alternatively libvirt allows full control over dnsmasq instance.
Comment 1 Daniel Berrange 2009-12-11 05:32:58 EST
This change is intentional. libvirt will always start dnsmasq because it is necessary to provide DNS and TFTPBoot services to guests using static IP config instead of DHCP.

The libvirt virtual network capability is not intended to allow arbitrary end user customization. If you require that, then the recommendation is to configure it directly, and use type=bridge in libvirt guest domain config for NICs, instead of type=network.

Note You need to log in before you can comment on or make changes to this bug.