Bug 546577 - Feature request: handling monitor dimming properly when the user is on a text console.
Feature request: handling monitor dimming properly when the user is on a text...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xfce4-power-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 04:34 EST by Cong Ma
Modified: 2009-12-11 06:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-11 06:44:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cong Ma 2009-12-11 04:34:53 EST
Description of problem:

Well, this is not really a "bug", but a request for enhancement.

I usually leave xfce4-power-manager on with the automatic dimming timeout set to two minutes. However, I usually find my self on a text console (ctrl-alt-Fn) for much longer than that. The power manager seems to pick up events in the desktop only, and that means I'll have to suffer the dimming even if I'm busy working on the console (since there are no keyboard/mouse events generated on the desktop). I know I could have temporarily disabled the monitor power management feature, but I prefer it happening automatically. (Yeah, I am so spoiled ;)

So the requested feature is that xfce4-power-manager should be able to know "where I am" -- on the desktop or the text console. It should turn off monitor power management (if it's on) as soon as I leave the desktop, and turn it back to the former state as soon as I leave the console and take control of the desktop again.

And that's it :-)

  
Actual results:

The power manager ignores the fact that I'm no longer on the desktop while still in front of the monitor, and goes on to dim the monitor.


Expected results:

It shouldn't have reduced the monitor brightness while I'm still in front of it.
Comment 1 Christoph Wickert 2009-12-11 06:44:20 EST
Please be so kind as to direct all feature requests to the upstream developer rather than the package maintainer. I cannot decide what to do, I can only forward your report upstream. Usually some information gets lost, I think you can explain better what you have in mind. By using upstream's bug tracker you will reach a wider audience and get more feedback.

Please file your request at bugzilla.xfce.org and CC me to it. TIA!

Note You need to log in before you can comment on or make changes to this bug.