Bug 54662 - Ugly konqueror fonts on default RH 7.1 install
Ugly konqueror fonts on default RH 7.1 install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
http://bugzilla.redhat.com/bugzilla/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-15 14:57 EDT by Bennett C. Baker
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-15 14:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bennett C. Baker 2001-10-15 14:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
Some web pages dsplay hideous fonts in konqueror on default RH 7.1
install.  A good example is the RH bugzilla main page.  Another good
example is the kernel.org home page.  The fonts look like they aren't
scaling correctly.  This can be palliated by changing the encoding to
anything but "auto" on the currently runnint konqueror instance
(right-click onthe konqueror window, select "Set encoding", and select
something other than "Auto") but the choice does not stick after shutting
down that konqueror instance and selecting non-Auto encoding on the main
settings page DOES NOT fix it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start up kdw on RH 7.1, either as default desktop or sleected by
"startkde" in .xinitrc.
2. Go to RH bugzilla main page or kernel.org main page
3. See blocky, practically unreadable fonts
	

Actual Results:  bad fonts

Expected Results:  readable fonts

Additional info:

Machine is Athlon 750, video is Matrox 450 in Xinerama mode at 2 x 1280 x
1024 (2 x Sony 500PS displays).  Navigator displays these pages just fine
both under KDE and Gnome.  So far, I've only found those two pages which
show the ugly fonts, but I'm sure there are others - I just haven't been
able to figure out the common element between them.
Comment 1 Bernhard Rosenkraenzer 2001-10-24 10:12:05 EDT
This was specific to some graphics cards and installs with all packages (or at 
least all font packages) installed, that's why it went unnoticed (I'm using 
Konqueror exclusively).

It's been fixed in 7.2.
Comment 2 Luca Bonomi 2001-10-25 04:26:16 EDT
I have just installed RH 7.2 and I still see the font problem using konqueror.
Fonts look ugly, but not unreadable, on some pages (e.g. http://groups.google.com/).
I am using a Matrox G400 card on a default RH 7.2.

It seems like this problem appears when the <FONT FACE=xxx> tag is used in html 
code.
Comment 3 Luca Bonomi 2001-10-25 07:02:20 EDT
Some additional comment to my previous posting.
This problem seems to be solved if you remove the line

/usr/share/AbiSuite/fonts

from the font catalogue in "/etc/X11/fs/config".
Then restart the xfs server.

Seems like an xfs bug or some problems with the "abiword" fonts.
Comment 4 Bennett C. Baker 2001-10-25 11:08:58 EDT
I did some additional checking based on the suggestions by Luca Bonomi (thanks 
Luca!)  and found that the problem goes away if I remove the 
/usr/X11R6/lib/X11/fonts/misc entry from the xfs config file.  Note that the 
xxx:unscaled entry stays; it's only the scaled font entry that has to go.  I 
realize this bug is fixed in 7.2, but this workaround should help those poor 
souls who haven't yet upgraded.

Note You need to log in before you can comment on or make changes to this bug.