Bug 54672 - Internal error during installation after formatting new partitions
Internal error during installation after formatting new partitions
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-15 20:45 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 14:09:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message after disks are formatted (130.53 KB, text/plain)
2001-10-17 01:49 EDT, Need Real Name
no flags Details
File produced after formating crashed (deleted)
2001-10-28 18:47 EST, Dave Snaith
no flags Details

  None (edit)
Description Need Real Name 2001-10-15 20:45:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4m)

Description of problem:
After setting up the partitions (using fdisk) and specifying hardware, the
installer
should format the partitions and install the gnome package.  The progress
bar 
indicated that it formatted the partitions, but I am dubious since it took
less 
than a minute for a 4Gbyte and a 16 Gbyte partition.  Then I got an error
message
that said something like "internal error, notify bugzilla.redhat.com".  I
tried to save
the error message to a floppy, but this did not work.  I remember that the
error
message also said something about "anaconda line 500", but there was more
that
I did not get.  

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I tried the installation again, but now it gets to the step where it should
format
the partitions and it hangs.  It says "formatting partitions" and shows the
progress
bar, but it does not show any progress, and I do not hear anything from the
drive.
I left it in this state for 15-20 minutes, but it never recovered.

Actual Results:  System hangs.  See above.

Expected Results:  The partitions should be formatted and the software
should be installed.

Additional info:

I am trying to install the software on a Dell Inspiron 8100 laptop.  It
came
with Windows 2000 pre-installed.  I have been using it with Windows for
a couple weeks with no problems.  Now I can't even get it to boot to 
Windows.
Comment 1 Brent Fox 2001-10-16 14:21:47 EDT
It's going to be almost impossible for me to know what went wrong without the
debug error message.  Is there any way you can save it somehow?
Comment 2 Need Real Name 2001-10-17 01:49:48 EDT
Created attachment 34261 [details]
error message after disks are formatted
Comment 3 Need Real Name 2001-10-17 01:53:01 EDT
Further investigation showed that the problem is indeed reproducible
I get the "internal error" message every time I try to install the software.
(I did not get the error message once because I asked for the disk to
be checked for bad sectors and did not wait long enough before 
concluding that the system had hung.)  I could not save the error 
message in Redhat 7.1, but I tried to install a beta version of Redhat 
7.0 and got a similar message, which I was able to save (see attached).  

There are two other things that may or may not be related to the problem.
First, when the system is booting up for the linux installation, there is some
kind of X server error that I cannot read because it flashes on the screen
right before the screen is cleared.  Second, when the partitions are being
formatted, it also formats the swap partition, which I did not think was 
supposed to happen.  I partitioned the disk so that the swap partition is in 
the middle of the disk.  Some people have told me it is more common to 
put it at the end of the disk.
Comment 4 Brent Fox 2001-10-17 14:48:51 EDT
I think the bug you are seeing with the beta for 7.0 is not at all related to
the bug you are seeing with 7.1.  It would be more helpful if we had the 7.1
debug error message.  I don't know where to go next on this issue if we can't
get that information.
Comment 5 Brent Fox 2001-10-27 10:21:28 EDT
Any more info here?
Comment 6 Need Real Name 2001-10-27 17:01:49 EDT
I got Redhat 6.2 to install and then I tried to install Redhat 7.1 as an
upgrade.
Redhat 7.1 seemed to install OK, but after the software finished installing, I
tried
to boot the computer and got LI...  The system starts to boot and "L" and "I"
appear on the screen, but then the system hangs (rather than finishing LILO
and booting).  I haven't had a chance to do anymore.

Concerning the error logfile from when I tried to install 7.1 directly, the fact
that the
logfile will not be saved to disk should be considered a bug.  This is
reproducable
as I tried many times to save that logfile to multiple disks and failed.  When I
tried
7.0.98, the logfile saved with no problems and that is what I sent you before.
Comment 7 Michael Fulbright 2002-01-15 14:08:58 EST
There are many issues being discussed here, for several different version of Red
Hat Linux.

Could you please summarize the issue you are seeking assistance with so I can
help you better?
Comment 8 Brent Fox 2002-01-26 22:48:37 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.