Bug 54673 - Missing fonts in tetex-fonts [ghostscript]
Summary: Missing fonts in tetex-fonts [ghostscript]
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard: triage|leonardjo|closed|notabug
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-16 01:08 UTC by R (Chandra) Chandrasekhar
Modified: 2013-07-02 22:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 20:08:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pkerror.log file for bug 54673 (14.13 KB, text/plain)
2001-10-16 01:10 UTC, R (Chandra) Chandrasekhar
no flags Details
zip archive of sample .tex file, intermediate and final results (10.91 KB, patch)
2001-10-16 09:43 UTC, R (Chandra) Chandrasekhar
no flags Details | Diff
Result of doing 'rpm -V tetex tetex-fonts tetex-xdvi' (1.30 KB, text/plain)
2001-10-16 10:23 UTC, R (Chandra) Chandrasekhar
no flags Details
xdvi error log after installation of tetex-1.0.7-15.i386.rpm (11.17 KB, text/plain)
2001-10-16 12:28 UTC, R (Chandra) Chandrasekhar
no flags Details
Whole file from trace -Ff -s1000 gsftopk ptmr8r 622 2>/tmp/log (642.01 KB, text/plain)
2001-10-16 13:33 UTC, R (Chandra) Chandrasekhar
no flags Details

Description R (Chandra) Chandrasekhar 2001-10-16 01:08:52 UTC
Description of Problem: With tetex-fonts-1.0.7-32.i386.rpm, I cannot get
fonts to use with xdvi/kdvi.  Specificaly, the missfonts.log file is:

mktexpk --mfmode cx --bdpi 300 --mag 2+22/300 --dpi 622 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+132/300 --dpi 432 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+218/300 --dpi 518 ptmb8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 ptmri8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 psyr
mktexpk --mfmode cx --bdpi 300 --mag 2+22/300 --dpi 622 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+132/300 --dpi 432 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+218/300 --dpi 518 ptmb8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 ptmr8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 ptmri8r
mktexpk --mfmode cx --bdpi 300 --mag 1+60/300 --dpi 360 psyr


Version-Release number of selected component (if
applicable):tetex-fonts-1.0.7-32.i386.rpm


How Reproducible: The \usepackage commans in my LaTeX file are:

(a) In class file:

\RequirePackage{times} % specified font
\RequirePackage{mathptm} % math support

(b) In .tex file:

\usepackage{url} % for citing www addresses
\usepackage{cite} % for references [5--7] etc.
\usepackage{fancyhdr}
\usepackage{array}


Steps to Reproduce:
1. Run latex on a sample file, say sample.tex
2. xdvi sample.dvi &> pkerror.log 
3. Capture error log 

Actual Results: I will attach my pkerror.log and missfont.log files
resulting from a specific .tex file.


Expected Results: No errors on font generation


Additional Information: I have upgraded my tetex -fonts from version 15 to
32 in the hope that the bug may be corrected (I use RedHat Linux 7.1) but
the problem did not go away.  I use KDE 2.2 with anti-aliased fonts. 
Removing that did not make the problem go away.  Otherwise, I have a
standard RedHat 7.1 installation.

Comment 1 R (Chandra) Chandrasekhar 2001-10-16 01:10:33 UTC
Created attachment 34161 [details]
pkerror.log file for bug 54673

Comment 2 Tim Waugh 2001-10-16 08:01:11 UTC
Please attach a small but complete example.


Comment 3 R (Chandra) Chandrasekhar 2001-10-16 09:43:25 UTC
Created attachment 34183 [details]
zip archive of sample .tex file, intermediate and final results

Comment 4 Tim Waugh 2001-10-16 09:55:58 UTC
Thanks.  Well, it works for me. :-/

What is the output of 'rpm -V tetex tetex-fonts tetex-xdvi'?  For me there is 
no output, indicating that the installed files and directories match what the 
package thinks should be there.


Comment 5 R (Chandra) Chandrasekhar 2001-10-16 10:22:23 UTC
Doing 

'rpm -V tetex tetex-fonts tetex-xdvi'

gives the file diff.log that I will attach.  Obviously, not everything is in
place because it is not empty.

I updated my pdftex because there were errors with some PDF graphics files when
the packaged pdftex was used.  For this, I used section 5 of my HOW TO at:

http://www.arcme.uwa.edu.au/~chandra/LaTeX2PDF/LaTeX2PDF.html#tth_sEc5

and there were no problems with pdftex/pdflatex.

I wonder if this has caused some problems that have propagated.


Comment 6 R (Chandra) Chandrasekhar 2001-10-16 10:23:15 UTC
Created attachment 34184 [details]
Result of doing 'rpm -V tetex tetex-fonts tetex-xdvi'

Comment 7 Tim Waugh 2001-10-16 10:30:15 UTC
Perhaps.  tetex-1.0.7-31 onwards has pdftex 0.14h; could you try reinstalling the 
tetex package (rpm -Uvh tetex-1.0.7-32.i386.rpm --force) and see if that makes a 
difference?


Comment 8 R (Chandra) Chandrasekhar 2001-10-16 12:01:00 UTC
rpm -Uvh tetex-1.0.7-32.i386.rpm --force

gives

error: failed dependencies:
        libpng.so.3   is needed by tetex-1.0.7-32
        perl(L2hos)   is needed by tetex-1.0.7-32
        perl(strict)   is needed by tetex-1.0.7-32
        perl(vars)   is needed by tetex-1.0.7-32

It looks like I need to re-install other packages as well.

Comment 9 Tim Waugh 2001-10-16 12:04:37 UTC
Oh, that's right, the perl and png dependencies.  Grr.

Is it too much trouble to reinstall tetex-1.0.7-15.i386.rpm in the same manner, and try 
xdvi at that stage, before upgrading pdftex?



Comment 10 R (Chandra) Chandrasekhar 2001-10-16 12:26:40 UTC
I did

rpm -Uvh tetex-1.0.7-15.i386.rpm --force
Preparing...                ########################################### [100%]
   1:tetex                  ########################################### [100%]

It installed OK.

Then I did 

latex bugsample.tex
xdvi bugsample.dvi &> xdvierror.log &

Log file is attached.  Same errors persist.

Comment 11 R (Chandra) Chandrasekhar 2001-10-16 12:28:07 UTC
Created attachment 34189 [details]
xdvi error log after installation of tetex-1.0.7-15.i386.rpm

Comment 12 Tim Waugh 2001-10-16 12:48:47 UTC
Output of 'df -h', just to rule out disk space issues?


Comment 13 Tim Waugh 2001-10-16 12:59:17 UTC
Also, it would be handy to see the last few hundred or so lines of /tmp/log in:

strace -Ff -s1000 gsftopk ptmr8r 622 2>/tmp/log



Comment 14 R (Chandra) Chandrasekhar 2001-10-16 13:22:23 UTC
df -h

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2             1.9G  1.5G  424M  78% /
/dev/hda6              12G  1.1G   10G   9% /localhost
/dev/hda1             2.9G  886M  1.8G  32% /localhost/VMachine
odin:/home/res        106G   32G   69G  32% /.automount/odin/home/res

As myself:
strace -Ff -s1000 gsftopk ptmr8r 622
bash: strace: command not found

As root:
strace -Ff -s1000 gsftopk ptmr8r 622
bash: strace: command not found

So I do not know how to execute the last command
strace -Ff -s1000 gsftopk ptmr8r 622 2>/tmp/log


Comment 15 Tim Waugh 2001-10-16 13:26:09 UTC
Please install the strace package.  You should run the command as yourself.


Comment 16 R (Chandra) Chandrasekhar 2001-10-16 13:33:52 UTC
Created attachment 34190 [details]
Whole file from trace -Ff -s1000 gsftopk ptmr8r 622 2>/tmp/log

Comment 17 Tim Waugh 2001-10-16 13:50:37 UTC
How about 'rpm -q ghostscript'?  What's going wrong is that ghostscript sends 
all its output, gsftopk closes its pipe and waits for ghostscript to exit, and 
then ghostscript says 'what now?' ("GS>").



Comment 18 R (Chandra) Chandrasekhar 2001-10-16 22:54:54 UTC
rpm -q ghostscript

gives 

ghostscript-7.00-1

rpm -qi ghostscript gives

Name        : ghostscript                  Relocations: (not relocateable)
Version     : 7.00                              Vendor: artofcode LLC
Release     : 1                             Build Date: Wed 06 Jun 2001 11:11:10
WST
Install date: Mon 24 Sep 2001 19:05:54 WST      Build Host: eros.ee.uwa.edu.au
Group       : Applications/Graphics         Source RPM:
ghostscript-7.00-1.src.rpm
Size        : 6783749                          License: Aladdin Free Public
License, artocode LLC
Packager    : Russell Lang <gsview@ghostgum.com.au>
URL         : http://www.cs.wisc.edu/~ghost/
Summary     : PostScript interpreter and renderer
Description :
Ghostscript is a PostScript interpreter. It can render both PostScript
and PDF compliant files to devices which include an X window, many printer
formats (including support for colour printers), and popular graphics
file formats.


Comment 19 Alexei Podtelezhnikov 2001-10-17 04:19:57 UTC
this version of ghostscript is unsupported by Red Hat.
Go back to 6.51 from rawhide at least.

Comment 20 R (Chandra) Chandrasekhar 2001-10-17 05:48:19 UTC
Thanks.

I installed:

ghostscript-6.51-15.i386.rpm         ttfonts-1.0-4.noarch.rpm
ghostscript-fonts-5.50-4.noarch.rpm  ttfonts-ja-1.0-6.noarch.rpm

the last because it was needed by ghostscript-6.51-15.i386.rpm (I do not use
Japanese fonts myself).

On completing this, and running xdvi/kdvi on bugsample.dvi, there were no error
messages and the display was as expected.

The ghostscript-7.00-1 rpm was compiled from source by one of our staff at my
centre: I will keep him posted of the problem that arose from it.

I will try to update my pdftex set up and see if I am back to status quo ante
with everything else in place as it is.

Many thanks for your patience and perseverance in tracking this down!

Comment 21 Sammy 2001-10-17 17:35:06 UTC
What I see from the pkerror.log file is that gs is dying because it is not
configured properly somehow.

I am running this version with gs-7.00 and gs-7.02 (rpms generated by me
from the source rpm). One does need to configure things to agree with
RedHat setup, obviously.


Comment 22 Leonard den Ottolander 2004-11-04 20:08:07 UTC
Comment 20 suggests this was a user error after all.

Closing NOTABUG.



Note You need to log in before you can comment on or make changes to this bug.