Bug 547119 - Impossible to hot-rezise LUKS volume (cryptsetup resize)
Summary: Impossible to hot-rezise LUKS volume (cryptsetup resize)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Milan Broz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 549927 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-13 17:28 UTC by Michel P
Modified: 2013-03-01 04:07 UTC (History)
10 users (show)

Fixed In Version: 1.1.0-0.4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 04:40:19 UTC
Type: ---


Attachments (Terms of Use)

Description Michel P 2009-12-13 17:28:25 UTC
Description of problem:

For example if you want to grow a filesystem on a LUKS volume on top of a LVM logical volume you have to resize the logical volume, then resize the LUKS container and then grow the filesystem.

The problem is in step 2 when using the "cryptsetup resize" command to resize the LUKS volume to the new volume size.

Version-Release number of selected component (if applicable):
cryptsetup-luks-1.1.0-0.1.fc12.i686
cryptsetup-luks-libs-1.1.0-0.1.fc12.i686

How reproducible:
Try to grow a filesystem on a LUKS volume without closing/reopening it

Steps to Reproduce:
1. Create a LV formated with LUKS or use an existing one
2. Grow the LV
3. run "cryptsetup resize name-of-luks-volume"
  
Actual results:

# cryptsetup resize system-smtest-clear
Device (null) doesn't exist or access denied.
Command failed: Device (null) doesn't exist or access denied.

The volume is not resized

# cryptsetup resize /dev/mapper/system-smtest-clear
gives the same result

Expected results:

No output and the LUKS volume resized

Additional info:

commands to reproduce with existing VG named system:
# lvcreate -L 1G -n smtest system
# cryptsetup luksFormat /dev/mapper/system-smtest
# cryptsetup luksOpen /dev/mapper/system-smtest system-smtest-clear
# lvresize -L +1G system/smtest
# cryptsetup resize system-smtest-clear
Device (null) doesn't exist or access denied.
Command failed: Device (null) doesn't exist or access denied.

Comment 1 Milan Broz 2009-12-13 17:44:46 UTC
Forgot to update cryptsetup in F12, I'll prepare update tommorow.

For the time being you can use rawhide version, it is fixed already.

Comment 2 Milan Broz 2009-12-14 15:51:08 UTC
Fixed in cryptsetup-luks-1.1.0-0.4.fc12.

Comment 3 Fedora Update System 2009-12-14 16:50:53 UTC
cryptsetup-luks-1.1.0-0.4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cryptsetup-luks-1.1.0-0.4.fc12

Comment 4 Fedora Update System 2009-12-16 01:03:57 UTC
cryptsetup-luks-1.1.0-0.4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cryptsetup-luks'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13153

Comment 5 Fedora Update System 2009-12-22 04:40:15 UTC
cryptsetup-luks-1.1.0-0.4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Milan Broz 2009-12-23 10:22:26 UTC
*** Bug 549927 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.