Bug 54723 - memory fault in tc
memory fault in tc
Status: CLOSED DUPLICATE of bug 54914
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
Depends On:
  Show dependency treegraph
Reported: 2001-10-16 19:22 EDT by Russell Stuart
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-16 19:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Russell Stuart 2001-10-16 19:22:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14.ext3 i686)

Description of problem:
When listing the classes for a prio qdisc tc gets a memory fault.

Version-Release number of selected component (if applicable):
tested on iproute-2.2.4-7 & iproute-2.2.4-10

How reproducible:

Steps to Reproduce:
Run these commands as root:

# modprobe ip_gre
# ip tunnel add test-tun mode gre local remote
# tc qdisc add dev test-tun root handle 123:0 prio
# tc class list dev test-tun
Memory fault (core dumped)

Actual Results:  Memory fault in tc_class.c/print_class(), line 234

Expected Results:  The classed for qdisc 123:0 should of been listed.

Additional info:
Comment 1 Phil Knirsch 2001-10-25 10:26:00 EDT

*** This bug has been marked as a duplicate of 54914 ***
Comment 2 Phil Knirsch 2002-05-27 07:47:10 EDT
Is fixed in iputils-2.4.7-2, available from current release (RH 7.3).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.