Bug 547297 - Folder .gvfs does not have the right permissions
Folder .gvfs does not have the right permissions
Status: CLOSED DUPLICATE of bug 540574
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-14 05:21 EST by Fabien Archambault
Modified: 2015-03-03 17:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-14 08:28:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabien Archambault 2009-12-14 05:21:04 EST
Description of problem:
Impossible to list /home/user folder

Version-Release number of selected component (if applicable):
 Fedora 12

How reproducible:
Every time when occuring

Steps to Reproduce:
1. I do not know how it appeared
  
Actual results:
ls -l /home/user => works
ls -al /home/user
(waiting for hours and still nothing shown)
Problem occurs in "user".
In "root" :
# ls -alrt /home/MarbolanGos/
ls: cannot access /home/MarbolanGos/.gvfs: Permission denied
total 570680
d??????????  ? ?           ?                   ?                ? .gvfs
......
(not shown all folder)

Expected results:
List all folders including hidden.

Additional info:
Tried to remove or modify the folder (in root and user) :
# rm -Rf  /home/MarbolanGos/.gvfs
rm: cannot remove `/home/MarbolanGos/.gvfs': Permission denied
# chown root:root /home/MarbolanGos/.gvfs
chown: cannot access `/home/MarbolanGos/.gvfs': Permission denied
[root@fedora ~]# chmod 777 /home/MarbolanGos/.gvfs
chmod: cannot access `/home/MarbolanGos/.gvfs': Permission denied

Found a solution now working with a small "patch" (http://www.pubbs.net/fedora/200908/1947/) :
create file : /etc/X11/xinit/xinitrc.d/00-gvfs-disable-fuse.sh
Add inside :
GVFS-DISABLE-FUSE=1
export GVFS-DISABLE-FUSE

Now :
ls -al /home/MarbolanGos
...
dr-x------.  2 MarbolanGos MarbolanGos         0 2009-12-09 00:21 .gvfs
...
Comment 1 Tomáš Bžatek 2009-12-14 08:28:20 EST

*** This bug has been marked as a duplicate of bug 540574 ***

Note You need to log in before you can comment on or make changes to this bug.