Bug 547685 - Brightness Applet slider hides when clicked
Brightness Applet slider hides when clicked
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-15 07:33 EST by Ales Zelinka
Modified: 2011-06-27 10:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 10:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixed it for me (1.43 KB, patch)
2010-05-15 06:04 EDT, Tore Anderson
no flags Details | Diff

  None (edit)
Description Ales Zelinka 2009-12-15 07:33:07 EST
Description of problem:
I can't use the slider or +/- buttons from brightness applet because the slider disappear the moment I click it.

I can still click the applet for the slider to appear and then use mouse-wheel or arrow keys to adjust the brightness


Version-Release number of selected component (if applicable):
gnome-power-manager-2.29.1-1.fc13.x86_64
Comment 1 Matthias Clasen 2010-02-19 21:34:54 EST
I can confirm this.
Comment 2 Bug Zapper 2010-03-15 09:35:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Colin Macdonald 2010-05-04 16:17:22 EDT
Me too.  Worked fine in F12, same hardware.
Comment 4 Tore Anderson 2010-05-15 05:38:56 EDT
+1.  Anyone found a workaround?

Tore
Comment 5 Tore Anderson 2010-05-15 06:04:43 EDT
Created attachment 414232 [details]
Patch that fixed it for me

Found this patch in the Ubuntu bug report (https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/535097).  It works for me, at least.

Tore
Comment 6 Werner Gold 2010-07-05 03:30:58 EDT
Still doesn't work in in F13.
Comment 7 Richard Hughes 2010-07-13 06:50:08 EDT
I'm not sure how to fix this with GTK3. Ideas welcome.
Comment 8 Ales Zelinka 2010-07-15 04:04:55 EDT
I don't have any F13 system around now but AFAIK the sliding widget was the same as in volume setting applet and that one was working. Maybe take a look how it does it? (or check what's different in rhel6 beta because brightness applet slider works there)
Comment 9 Andrew Lofthouse 2010-08-24 09:07:48 EDT
(In reply to comment #5)
> Created attachment 414232 [details]
> Patch that fixed it for me

Works for me as well...
Comment 10 Bug Zapper 2011-06-02 13:07:23 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2011-06-27 10:41:45 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.