Bug 54791 - Up2date gets TypeError installing latest kernel update
Up2date gets TypeError installing latest kernel update
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 21:05 EDT by Need Real Name
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 15:14:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-18 21:05:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
Running up2date to install the latest rh7.1 kernel update, I get this
error in the installation phase and up2date hangs, and must be killed:

[root@bergum-w2k bergum]# Traceback (innermost last):
  File "/usr/share/rhn/up2date/gui.py", line 592, in doInstallation
    kernelsToInstall = up2date.installPackages(self.selectedPkgList,
self.rpmCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 2158, in installPackages
    error = errors + e + "\n"
TypeError: illegal argument type for built-in operation

Running up2date-2.5.4-1.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run up2date
2.Select kernel upgrades
3.Keep hitting next until it hangs.
	

Actual Results:  Up2date hangs in the installation phase.

Expected Results:  New kernel installed!

Additional info:
Comment 1 Adrian Likins 2001-10-24 16:34:33 EDT
A cause for this is that the rpm kernel package
install failed for some reason (a typical one
being not enough space in /boot).

The proper error message isnt raised because
of a bug in the error handling code. This
will be fixed in the next version of the up2date
client.
Comment 2 Need Real Name 2001-10-24 18:03:47 EDT
I fixed the typo in the python code, and the install ran just fine.  I think
that the typo results in a python compile time error, as when I fixed the code
there was no error message printed, and the install ran just fine.
Comment 3 Adrian Likins 2001-11-01 18:01:04 EST
should be fixed in next release of code
Comment 4 David M. Cook 2001-11-06 15:13:55 EST
Verified kernel update and typo fix.
Comment 5 David M. Cook 2002-02-22 12:29:42 EST
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.