This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54793 - X emacs is coredumping.
X emacs is coredumping.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 21:23 EDT by Jonathan Kamens
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-21 20:57:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-10-18 21:23:09 EDT
I upgraded to the 20.7-43 Rawhide emacs packages (emacs, emacs-X11,
emacs-el).  Now Emacs is coredumping when I try to run it in X mode:

Program received signal SIGSEGV, Segmentation fault.
0x4009384e in XtInitializeWidgetClass () from /usr/X11R6/lib/libXt.so.6
(gdb) where
#0  0x4009384e in XtInitializeWidgetClass () from /usr/X11R6/lib/libXt.so.6
#1  0x40094304 in _XtCreateWidget () from /usr/X11R6/lib/libXt.so.6
#2  0x400944ed in XtCreateWidget () from /usr/X11R6/lib/libXt.so.6
#3  0x08090d25 in XMapRaised ()
#4  0x08091d1e in XMapRaised ()
#5  0x080f4b40 in error ()
#6  0x0811e56d in error ()
#7  0x080f5167 in error ()
#8  0x080f4c78 in error ()
#9  0x0811e56d in error ()
#10 0x080f5167 in error ()
#11 0x080f4c78 in error ()
#12 0x0811e56d in error ()
#13 0x080f5167 in error ()
#14 0x080f4c78 in error ()
#15 0x0811e56d in error ()
#16 0x080f5167 in error ()
#17 0x080f4c78 in error ()
#18 0x0811e56d in error ()
#19 0x080f5167 in error ()
#20 0x080f4ebf in error ()
#21 0x080f3f3c in error ()
#22 0x0809ade2 in abort ()
#23 0x080f2cba in re_compile_pattern ()
#24 0x0809ae1b in abort ()
#25 0x080f283e in re_compile_pattern ()
#26 0x0809ad1a in abort ()
#27 0x0809a941 in abort ()
#28 0x0809aa4d in abort ()
#29 0x08099a97 in abort ()
#30 0x40265306 in __libc_start_main (main=0x8098f00 <abort+1408>, argc=1, 
    ubp_av=0xbffff984, init=0x804c864 <_init>, fini=0x812fba0 <_fini>, 
    rtld_fini=0x4000d2cc <_dl_fini>, stack_end=0xbffff97c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 

I downloaded the SRPM and rebuilt it, and it doesn't coredump anymore.  I
suspect a problem in the binutils used to build the Emacs RPM, especially
since there's at least one known problem in the current rawhide binutils. 
I'm running a previous binutils version (2.11.90.0.8-8) because I ran into
that problem.  Other than that old binutils version, I'm up-to-date with
all the other Rawhide packages.
Comment 1 Trond Eivind Glomsrxd 2001-10-21 20:57:36 EDT
Will probably be fixed the next time it's rebuilt... keeping this open until then.
Comment 2 Trond Eivind Glomsrxd 2001-10-22 12:23:10 EDT
emacs 21.1-0.1 and above should fix this.

Note You need to log in before you can comment on or make changes to this bug.