Bug 547994 - Logical Volume Management: Parse Error
Logical Volume Management: Parse Error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
12
i686 Linux
low Severity low
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 05:00 EST by Runwalsoft
Modified: 2010-05-11 09:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 09:15:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bootlog (3.00 KB, application/octet-stream)
2009-12-16 05:00 EST, Runwalsoft
no flags Details
lvm.conf (18.35 KB, application/octet-stream)
2009-12-16 23:44 EST, Runwalsoft
no flags Details
All lvm files and folders. (9.53 KB, application/zip)
2009-12-17 07:25 EST, Runwalsoft
no flags Details

  None (edit)
Description Runwalsoft 2009-12-16 05:00:20 EST
Created attachment 378723 [details]
Bootlog

Description of problem:
Whenever I got my machine I got 
Setting up Logical Volume Management:   Parse error at byte 135 (line 7): expected a value

Version-Release number of selected component (if applicable):
Fodora 12

How reproducible:
For every refresh I am getting this error.

Steps to Reproduce:
1. Start computer and we can see this message.
2.
3.
  
Actual results:
There should not be any error

Expected results:
while booting there should not be error

Additional info:
Comment 1 Peter Rajnoha 2009-12-16 06:47:37 EST
Did you edit /etc/lvm/lvm.conf? Please, attach this file too. Thanks.
Comment 2 Peter Rajnoha 2009-12-16 06:51:36 EST
(..or better try running "lvmdump" if possible and attach the file here)
Comment 3 Runwalsoft 2009-12-16 23:44:00 EST
Output of lvmdump
----------
[Manish@runwalsoft Documents]$ su -
Password: 
[root@runwalsoft ~]# lvmdump
Could not run lvm binary 'lvm'
[root@runwalsoft ~]# whereis lvmdump
lvmdump: /sbin/lvmdump /usr/share/man/man8/lvmdump.8.gz
You have mail in /var/spool/mail/root
[root@runwalsoft ~]# cd /sbin/lvmdump
-bash: cd: /sbin/lvmdump: Not a directory
[root@runwalsoft ~]# cd /sbin/
[root@runwalsoft sbin]# lvmdump
Could not run lvm binary 'lvm'
[root@runwalsoft sbin]#
-------------

And Attached in lvm.conf
Comment 4 Runwalsoft 2009-12-16 23:44:40 EST
Created attachment 378890 [details]
lvm.conf
Comment 5 Peter Rajnoha 2009-12-17 05:15:03 EST
(In reply to comment #3)
> Output of lvmdump
> ----------
> [Manish@runwalsoft Documents]$ su -
> Password: 
> [root@runwalsoft ~]# lvmdump
> Could not run lvm binary 'lvm'

Oh.. could you please gather the files manually then - I would need the whole contents of "/etc/lvm" dir (..pack it it one file, please).

Also, the output of "rpm -qa device-mapper*" and "rpm -qa lvm2*". Thanks.
Comment 6 Runwalsoft 2009-12-17 07:19:34 EST
# rpm -qa device-mapper*
device-mapper-devel-1.02.38-2.fc12.i686
device-mapper-event-1.02.38-2.fc12.i686
device-mapper-event-libs-1.02.38-2.fc12.i686
device-mapper-multipath-0.4.9-5.fc12.i686
device-mapper-libs-1.02.38-2.fc12.i686
device-mapper-multipath-libs-0.4.9-5.fc12.i686
device-mapper-1.02.38-2.fc12.i686
# rpm -qa lvm2*
lvm2-libs-2.02.53-2.fc12.i686
lvm2-2.02.53-2.fc12.i686

attached zip files of lvm
Comment 7 Runwalsoft 2009-12-17 07:25:11 EST
Created attachment 378977 [details]
All lvm files and folders.

Please note that I was running fedora 10 at start working. Then upgraded fedora 11. and within 2 week I upgraded F12. and its being few weeks that I am using F12.

I am not sure whether its being concern with another bug which I am facing.
https://bugzilla.redhat.com/show_bug.cgi?id=544935

As I am just trying to help and get resolve issue.
Comment 8 Peter Rajnoha 2009-12-17 08:00:59 EST
Hmm, there's a problematic character sequence in the /etc/lvm/cache/.cache line that causes the problem - the "^@":

  /dev/di^@k/by-uu^@d/2d6d5^@36-84a0^@461f-a610-5f5a43a38ef5

Actually, all of these are zeroes when I looked in hexa directly...

You can remove this cache file manually, it will always be recreated by lvm. But I'm wondering how this char sequence got there.

Can you try to find the item in /dev directly? Do you see it garbled there, too? If yes, then this could also be some udev daemon error not creating the names properly...

Anyway, it's quite interesting how did those "zeroes" get there...
Comment 9 Milan Broz 2009-12-17 08:05:51 EST
> [root@runwalsoft ~]# lvmdump
> Could not run lvm binary 'lvm'

> /dev/di^@k/by-uu^@d/2d6d5^@36-84a0^@461f-a610-5f5a43a38ef5

There is quite possible hw memory corruption btw. Is your system stable otherwise?
Comment 10 Runwalsoft 2009-12-19 23:05:43 EST
Looks like this is fixed. As far as /dev is concern I don't see any suspicious their. but if you want to see specific thing then give me list of commands so that I will execute and provide you output.

is it related with this error as well ?
https://bugzilla.redhat.com/show_bug.cgi?id=544935


Thank your for your support.
Comment 11 Peter Rajnoha 2010-05-11 08:19:47 EDT
(In reply to comment #10)
> Looks like this is fixed.

Have you encountered this problem since then? After you removed the /etc/lvm/.cache file manually, has the error come into the way again?
Comment 12 Runwalsoft 2010-05-11 09:04:40 EDT
This error have been resolved. Actually broken RAM was creating the problem. once I used new RAM then its not giving me any error. so you can close this issue.
Comment 13 Peter Rajnoha 2010-05-11 09:15:45 EDT
OK, closing then...

Note You need to log in before you can comment on or make changes to this bug.