Bug 548007 - [abrt] crash detected in gbirthday-0.5.5-1.fc12
Summary: [abrt] crash detected in gbirthday-0.5.5-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gbirthday
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e7351839
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-16 10:47 UTC by Donald Edward Winslow
Modified: 2009-12-22 04:55 UTC (History)
5 users (show)

Fixed In Version: 0.5.6-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 04:55:23 UTC


Attachments (Terms of Use)
File: backtrace (978 bytes, text/plain)
2009-12-16 10:47 UTC, Donald Edward Winslow
no flags Details

Description Donald Edward Winslow 2009-12-16 10:47:21 UTC
abrt 1.0.0 detected a crash.

Comment: I installed updates (one was for gbirthday) and rebooted. The bug reporting tool reported that evolution-data-server and gbirthday both crashed.

backtrace
-----
Summary: TBe7351839 databases.py:239:parse:AttributeError: 'NoneType' object has no attribute 'get_all_contacts'

Traceback (most recent call last):
  File "/usr/bin/gbirthday", line 3, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/gbirthday/__init__.py", line 178, in main
    start(ab, conf)
  File "/usr/lib/python2.6/site-packages/gbirthday/__init__.py", line 89, in start
    db.parse(ab=ab, conf=conf)
  File "/usr/lib/python2.6/site-packages/gbirthday/databases.py", line 239, in parse
    for contact in ebook.get_all_contacts():
AttributeError: 'NoneType' object has no attribute 'get_all_contacts'

Local variables in innermost frame:
evolution: <module 'evolution' from '/usr/lib/python2.6/site-packages/gtk-2.0/evolution/__init__.pyc'>
ab: <gbirthday.addressbook.AddressBook instance at 0xb770a20c>
title: Personal
self: <gbirthday.databases.Evolution instance at 0xb73b88ec>
ebook: None
book: default
conf: <gbirthday.Conf instance at 0xb7707fac>

cmdline: /usr/bin/python /usr/bin/gbirthday 
component: gbirthday
executable: /usr/bin/gbirthday
kernel: 2.6.31.6-166.fc12.i686
package: gbirthday-0.5.5-1.fc12
uuid: e7351839

Comment 1 Donald Edward Winslow 2009-12-16 10:47:23 UTC
Created attachment 378735 [details]
File: backtrace

Comment 2 Thomas Spura 2009-12-16 13:05:36 UTC
Very strange...

gbirthday asks evolution-data-server for all addressbooks and opens them.

It seems, evolution-data-server returned 'None' - whyever.

I'll have a look, if this is 'only' a issue for you or a general issue.

Another update will come this week,

Comment 3 Fedora Update System 2009-12-17 01:47:53 UTC
gbirthday-0.5.5-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gbirthday-0.5.5-3.fc12

Comment 4 Thomas Spura 2009-12-17 01:49:56 UTC
I'm quite unsure, if this fixes this issue, because I can't reproduce it on my box.


So, I guess this is fixed with this update ;)

Please test, when the update is pushed out to updates-testing and leave a comment in https://admin.fedoraproject.org/updates/gbirthday-0.5.5-3.fc12

Thank you very much.

Comment 5 Fedora Update System 2009-12-18 04:29:25 UTC
gbirthday-0.5.5-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gbirthday'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13319

Comment 6 Fedora Update System 2009-12-18 14:02:21 UTC
gbirthday-0.5.6-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gbirthday-0.5.6-1.fc12

Comment 7 Fedora Update System 2009-12-22 04:55:15 UTC
gbirthday-0.5.6-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.