Bug 54806 - AbiWord, old version, linked against to many libs, assertion `IS_COLOR_GROUP (P->color_group)' failed
AbiWord, old version, linked against to many libs, assertion `IS_COLOR_GROUP ...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: abiword (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-19 11:20 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-19 11:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-19 11:20:32 EDT
1) Newer versions than the ones RedHat ships can be found here:
http://prdownloads.sourceforge.net/abiword/
(0.9.4.1 currently, rh ships 0.7.14)

2) On Roswell (and rh 7.1 I think) I get these messages when opening documents:

** CRITICAL **: file color-palette.c: line 365 (custom_color_history_setup):
assertion `P->color_group != NULL' failed.

** CRITICAL **: file color-palette.c: line 483
(color_palette_get_current_color): assertion `IS_COLOR_GROUP (P->color_group)'
failed.

** CRITICAL **: file color-palette.c: line 365 (custom_color_history_setup):
assertion `P->color_group != NULL' failed.

** CRITICAL **: file color-palette.c: line 483
(color_palette_get_current_color): assertion `IS_COLOR_GROUP (P->color_group)'
failed.

According to
http://bugzilla.abisource.com/show_bug.cgi?id=1596
`It's a bug in GAL (Gnome Applications Library).
  File this on bugzilla.gnome.org if it isn't there already.'

Well the errors are coming from gal (btw neither GAL, libgal or gal
appear as products on bugzilla.gnome.org)
but the real problem appears to be that 

3) RedHat builds a version of abiword with *all* gnome stuff enabled. 
   Whereas Mandrake, Ximian, PLD all build a plain GTK version...

4) I would upload an abiword-0.9.4.1-1.src.rpm for redhat 7.1             
  however incoming.redhat.com appears to have died. Is that why the
  latest contribs are from August 27th ??
Comment 1 Bernhard Rosenkraenzer 2001-10-23 08:38:42 EDT
1) The more current releases have been made long after our feature freeze,
   so 0.7.14 had to stay for the 7.2 release.
2) is caused by 3)
3) was originally meant to integrate better with gnumeric.
   I've changed it in 0.9.4.1-1 because it causes more problems than it solves.
4) Try http://rhcontrib.bero.org/ - I've put up a (better ;) ) replacement
   when incoming was taken offline.


Note You need to log in before you can comment on or make changes to this bug.