Bug 54822 - up2date failed to complete kernel 2.4.9-6 upgrade
up2date failed to complete kernel 2.4.9-6 upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-19 15:31 EDT by Need Real Name
Modified: 2015-01-07 18:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-04 05:03:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-19 15:31:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77C-SGI [en] (X11; U; IRIX 6.5 IP32)

Description of problem:
I was running the 2.4.3-12 kernel.  Using up2date I went to upgrade to
2.4.9-6.  I'm using up2date-2.5.4-1, no firewall, no proxies.  Here's the
log from up2date:

[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date getAvailablePackageList from network
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date GetHeaders from network:
['diffutils-2.7-23', 'e2fsprogs-1.23-1.7.1', 'e2fsprogs-devel-1.23-1.7.1',
'filesystem-2.1.0-2.1', 'initscripts-5.84.1-1', 'kernel-2.4.9-6',
'kernel-doc-2.4.9-6', 'kernel-headers-2.4.9-6', 'kernel-source-2.4.9-6',
'mkinitrd-3.2.6-1', 'modutils-2.4.6-4']
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date getAdvisoryInfo for diffutils-2.7-21
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date Downloading package: diffutils-2.7-23
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
e2fsprogs-1.23-1.7.1
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
e2fsprogs-devel-1.23-1.7.1
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
filesystem-2.1.0-2.1
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
initscripts-5.84.1-1
[Fri Oct 19 11:34:21 2001] up2date Downloading package: kernel-2.4.9-6
[Fri Oct 19 11:34:21 2001] up2date Downloading package: kernel-doc-2.4.9-6
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
kernel-headers-2.4.9-6
[Fri Oct 19 11:34:21 2001] up2date Downloading package:
kernel-source-2.4.9-6
[Fri Oct 19 11:34:21 2001] up2date Downloading package: mkinitrd-3.2.6-1
[Fri Oct 19 11:34:21 2001] up2date Downloading package: modutils-2.4.6-4
[Fri Oct 19 11:34:21 2001] up2date installing packages:
['diffutils-2.7-23', 'e2fsprogs-1.23-1.7.1', 'e2fsprogs-devel-1.23-1.7.1',
'filesystem-2.1.0-2.1', 'initscripts-5.84.1-1', 'kernel-2.4.9-6',
'kernel-doc-2.4.9-6', 'kernel-headers-2.4.9-6', 'kernel-source-2.4.9-6',
'mkinitrd-3.2.6-1', 'modutils-2.4.6-4'] 
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 1
[Fri Oct 19 11:34:21 2001] up2date Opening rpmdb in /var/lib/rpm/ with
option 0
[Fri Oct 19 11:34:21 2001] up2date Removing packages from package profile:
['diffutils-2.7-21', 'e2fsprogs-1.19-4', 'e2fsprogs-devel-1.19-4',
'filesystem-2.0.7-1', 'initscripts-5.84-1', 'kernel-doc-2.4.3-12',
'kernel-headers-2.4.3-12', 'kernel-source-2.4.3-12', 'mkinitrd-3.0.10-1',
'modutils-2.4.2-5']
[Fri Oct 19 11:34:21 2001] up2date Adding packages to package profile:
['diffutils-2.7-23', 'e2fsprogs-1.23-1.7.1', 'e2fsprogs-devel-1.23-1.7.1',
'filesystem-2.1.0-2.1', 'initscripts-5.84.1-1', 'kernel-2.4.9-6',
'kernel-doc-2.4.9-6', 'kernel-headers-2.4.9-6', 'kernel-source-2.4.9-6',
'mkinitrd-3.2.6-1', 'modutils-2.4.6-4']
[Fri Oct 19 11:34:21 2001] up2date Error communicating with server.  The
message was:
SSL_connect error

It looks like up2date bombed out after having communications problems and
never finished the kernel install by updating lilo.conf and whatever else
it needed to do.  I had to update lilo.conf by hand to finish the
upgrade.   Either that or the kernel-2.4.9-6 RPM's are broken and don't
include whatever is necessary for up2date to automatically rebuild
lilo.conf.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Need Real Name 2001-10-22 12:36:40 EDT
I have the same issue with the same internet config over a dedicated T1. Once 
lilo is hand edited the new kenel works fine, but why is this an issue???
Comment 2 Adrian Likins 2001-10-24 16:24:48 EDT
Looks to be two seperate issues. An ssl connect error shouldnt
have any impact on the state that the kernel package is left in.
Everything is downloaded first, then installed as a transaction,
then lilo.conf is updated. 

From looking at the logs, it seems that the packages installed
succesfully, and nothing raised an error when updating lilo.conf.

Do you happen to have a copy of the lilo.conf before or after
up2date ran? I'd like to take a look at them and see what happened
and add the lilo.confs to the test suite if need be.
Comment 3 Need Real Name 2001-10-24 17:05:43 EDT
Here is lilo.conf from before I used up2date to upgrade from 2.4.3-12 -->
2.4.9-6 and also after up2date finished.  Note that nothing in it was changed by
up2date:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/boot/vmlinuz-2.4.2-2
        label=linux.bak
        read-only
        root=/dev/hda6

image=/boot/vmlinuz-2.4.3-12
        label=linux
        root=/dev/hda6
        read-only

Note that when I used up2date to upgrade from 2.4.2-2 to 2.4.3.-12,
/var/log/up2date contained messages such as these when it updated lilo.conf:

[Thu Sep 27 15:20:33 2001] up2date Modifying lilo.conf to include the new kernel
info
[Thu Sep 27 15:20:33 2001] up2date Adding 2.4.3-12 to lilo.conf
[Thu Sep 27 15:20:33 2001] up2date Running lilo with the new configuration
[Thu Sep 27 15:20:33 2001] up2date Running "/sbin/mkinitrd --ifneeded
/boot/initrd-2.4.3-12.img 2.4.3-12" 
[Thu Sep 27 15:20:33 2001] up2date No initrd was created by mkinitrd
[Thu Sep 27 15:20:33 2001] up2date renaming the lilo.conf entry for linux to
linux.bak
[Thu Sep 27 15:20:33 2001] up2date making a backup copy of /etc/lilo.conf as
/etc/lilo.conf.up2date-1001622601.16
[Thu Sep 27 15:20:33 2001] up2date writing out the new /etc/lilo.conf
[Thu Sep 27 15:20:33 2001] up2date Running " /sbin/lilo -t -r /"  (lilo test
mode)
[Thu Sep 27 15:20:33 2001] up2date Running " /sbin/lilo -r / " 
[Thu Sep 27 15:20:33 2001] up2date lilo updated succesfully
Comment 4 Andrew Barber 2001-12-04 05:03:02 EST
Have tried to update kernel and get the following:-
[root@issus /boot]# up2date -p
Updating package profile...
[root@issus /boot]# up2date -l

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################


Name                                    Version        Rel
--------------------------------------------------------------
gdb                                     5.1            0.71
kernel                                  2.4.9          12
openssh                                 2.9p2          10.7
openssh-askpass                         2.9p2          10.7
openssh-askpass-gnome                   2.9p2          10.7
openssh-clients                         2.9p2          10.7
openssh-server                          2.9p2          10.7

[root@issus /boot]# up2date -u

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
Retrieving selected packages...
gdb:                        ########################## Done.
kernel:                     ########################## Done.
openssh:                    ########################## Done.
openssh-askpass:            ########################## Done.
openssh-askpass-gnome:      ########################## Done.
openssh-clients:            ########################## Done.
openssh-server:             ########################## Done.
Preparing...                ########################################### [100%]
   1:gdb                    ########################################### [ 14%]
   2:kernel                 ########################################### [ 28%]
   3:openssh                ########################################### [ 42%]
   4:openssh-askpass        ########################################### [ 57%]
   5:openssh-askpass-gnome  ########################################### [ 71%]
   6:openssh-clients        ########################################### [ 85%]
   7:openssh-server         ########################################### [100%]
Error installing lilo.conf  The message was:
test install of lilo failed
[root@issus /boot]#

Comment 5 Adrian Likins 2002-03-26 18:38:28 EST
I belive the current releases should have any kernel/bootloader
issues resolved. 

If you still see this issue, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.