Bug 5485 - Cannot Install RH 6.x on Hard Drive despite 4 gigs of unpartitioned space
Summary: Cannot Install RH 6.x on Hard Drive despite 4 gigs of unpartitioned space
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-04 06:49 UTC by sysop
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 14:29:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sysop 1999-10-04 06:49:14 UTC
The bug is in disk druid AND in fdisk.

I have a 25 gig IBM hard drive.  There are currently 2
win98 fat 32 partitions on it, both 10 gig apiece.  That
left me wiht roughly 5 gig or so.  When I went to create
a / partition in the installer, it told me that there was
not enough space to do the partitioning.  The same error
occured when trying to make a /boot partition.  Changing
the size of the attempt was ineffectual.  Then I tried
creating a /usr partition of 3 gig.  It worked.  I tried /
again, to no avail.  This  is not the first machine i have
experienced this problem on.

Comment 1 Jay Turner 2000-02-08 14:29:59 UTC
The problem is that Disk Druid will not allow you to create /boot or root
(depending on whether /boot is present) above the 1024 cylinder limit, as then
it is not bootable.  This is a safety feature to prevent people installing above
1024 cylinders and then not being able to boot their installations.

The workaround is to use fdisk to create the partitions that you would like to
create and then assign them in Disk Druid.  Keep in mind that you will need a
boot disk in order to boot the system, as lilo will not be able to see the boot
partition this high up in the cylinders.


Note You need to log in before you can comment on or make changes to this bug.