Bug 54865 - terminal not usable on change to runlevel 1
terminal not usable on change to runlevel 1
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
: 46223 55545 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-10-21 19:49 EDT by Hal Burgiss
Modified: 2007-04-18 12:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-06 12:28:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hal Burgiss 2001-10-21 19:49:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6custom i686; Nav)

Description of problem:
Changing runlevels to runlevel 1 results in an usable terminal. The command
line buffer is executed on character at a time  ('ps' results in 'p':
command not found).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot runlevel 3
2.int 1
3.type any command

Actual Results:  Any command is parsed one character at a time. 'ps' first
results in 'p: command not found'. Then just hitting Enter once, gets a 's:
command not found'. Any command longer than one character does not work. 

Expected Results:  Proper command execution.

Additional info:

Booting runlevel 1 works fine. Booting runlevel 1, then changing to 3 works
fine. Default shell is bash. This started after applying all recent updates
as a group (glibc, filesystem, etc). So I am not sure the util-linux update
is the culprit here. 

Also, the prompt is screwy and alternates between what should be a normal
looking rootshell prompt and my personal user bash prompt:

[hal@feenix hal]$
[hal@feenix hal]$
[hal@feenix hal]$
[hal@feenix hal]$
[hal@feenix hal]$

Consistently, after each command.
Comment 1 Michael Schwendt 2001-10-22 16:00:06 EDT
> Any command longer than one character does not work. 

After the error has happened once, entering a longer command or pressing return
a few times, seems to fix the virtual terminal (for me) for some time.

The probability of reproducing this bug increases with a newly booted machine at
run-level greater than 1, and then either run "init 1" or switch to a virtual
terminal and log in as root.
Comment 2 Bill Nottingham 2001-10-23 11:50:43 EDT
What SysVinit are you running?
Comment 3 Michael Schwendt 2001-10-23 17:53:48 EDT
SysVinit-2.78-17 which has been an errata update for Seawolf.

That single "bash: No job control for this shell" message from bug #54741
applies here, too.

FWIW, the problem seems to be gone with Enigma.
Comment 4 Hal Burgiss 2001-10-23 18:07:48 EDT
SysVinit-2.78-17 here also.
Comment 5 Bill Nottingham 2001-11-06 11:01:23 EST
*** Bug 55545 has been marked as a duplicate of this bug. ***
Comment 6 Andreas J. Bathe 2001-11-06 11:51:46 EST
after downgrading to util-linux-2.10s-13.7 from the 7.1 errata the symptom (also
descripted in bug # 55545)
disappeared, so I think this is the place where the bug sits :)
Comment 7 Bill Nottingham 2001-11-06 12:24:12 EST
*** Bug 46223 has been marked as a duplicate of this bug. ***
Comment 8 Elliot Lee 2002-01-04 14:18:52 EST

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.