This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 548674 - Live migration of KVM guest using virt-manager fails in Fedora12
Live migration of KVM guest using virt-manager fails in Fedora12
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
12
other All
low Severity urgent
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 01:00 EST by IBM Bug Proxy
Modified: 2010-12-03 20:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 20:30:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 57815 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-12-18 01:00:40 EST
=Comment: #0=================================================
SANTWANA SAMANTRAY <santwana.samantray@in.ibm.com> - 

guest xml file, strace of virt-manager, virt-manager.log

Live migration of KVM guest using virt-manager fails in Fedora12-rawhide release.

uname -a :Linux mx3350a.in.ibm.com 2.6.31.5-127.fc12.x86_64 #1 SMP Sat Nov 7 21:11:14 EST 2009
x86_64 x86_64 x86_64 GNU/Linux

Steps to reproduce:
When a VM is running, right-click on it, it will list a option for Migrate.
Select "Remote tunnel over ssh" as the Connection type.
Once it is connected to the destination machine after entering the remote
system's password, it is displayed in the virt-manager.
Right click on the VM and choose to migrate it to the new host added.
It gives error as:
Migrating vm=F12_rawhide from qemu:///system to qemu+ssh://root@mx3650b/system
DEBUG (error:76) Uncaught Error: Unknown failure : Unable to migrate guest:
 Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 657, in _async_migrate
    vm.migrate(dstconn)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1555, in migrate
    self.vm.migrate(destconn.vmm, flags, None, None, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 384, in migrate
    if ret is None:raise libvirtError('virDomainMigrate() failed', dom=self)
libvirtError: Unknown failure

And the below error is noticed in /var/log/message of the host:
libvirtd: 18:20:38.716: error : qemudDomainMigratePerform:7292 : operation failed: migrate failed:
info migrate#012Migration status: failed#015#012
=Comment: #2=================================================
B. N. POORNIMA <bnpoorni@in.ibm.com> - 
As per the information I gathered from Santwana, migration using qemu-kvm works fine but using
virsh, same error is seen. 
Looks like it is libvirt related issue.  Libvirt version used in the system is
libvirt-0.7.1-15.fc12.x86_64

=Comment: #3=================================================
B. N. POORNIMA <bnpoorni@in.ibm.com> - 
Santwana, 
Could you please attach the sosreport of the source system?
=Comment: #4=================================================
SANTWANA SAMANTRAY <santwana.samantray@in.ibm.com> - 
Hello Poornima,

I had tried attaching the sosreport of the source and destination machine, but it is giving an error
as below:

sosreport

sosreport (version 1.8)

Traceback (most recent call last):
  File "/usr/sbin/sosreport", line 916, in <module>
    sosreport()
  File "/usr/sbin/sosreport", line 473, in sosreport
    conf_disable_plugins = config.get("plugins", "disable").split(',')
  File "/usr/lib64/python2.6/ConfigParser.py", line 540, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'disable' in section: 'plugins'

Thanks,
Santwana

=Comment: #6=================================================
SANTWANA SAMANTRAY <santwana.samantray@in.ibm.com> - 
Hello Poornima,

This problem is still reproducible in the GA'ed version of Fedora12(k.v- 2.6.31.5-127.fc12.x86_64).

Thanks,
Santwana
Comment 1 IBM Bug Proxy 2010-01-07 05:41:13 EST
------- Comment From bnpoorni@in.ibm.com 2010-01-07 05:38 EDT-------
RedHat,
Do you have any updates on this?
Comment 2 IBM Bug Proxy 2010-02-02 01:40:46 EST
------- Comment From bnpoorni@in.ibm.com 2010-02-02 01:38 EDT-------
RedHat,
Can you please provide us with some update? Thanks!
Comment 3 Bug Zapper 2010-11-03 23:03:15 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-12-03 20:30:33 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.