Bug 54869 - Network Config menu item doesn't work.
Network Config menu item doesn't work.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 03:23 EDT by Gregory Leblanc
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 10:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Leblanc 2001-10-22 03:23:15 EDT
Description of Problem:
'neat' doesn't run.  When run on the command line, it produces a traceback

Version-Release number of selected component (if applicable):
rpm -q redhat-config-network
redhat-config-network-0.9-1

Additional Information:

[root@peecee gleblanc]# neat
Copying ifcfg-eth0 to devices and putting it into the default profile.
Copying /etc/hosts to default profile.
Copying /etc/resolv.conf to default profile.

** WARNING **: unknown widget class 'GnomeDialog'
Traceback (innermost last):
  File "/usr/sbin/neat", line 1094, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 192, in __init__
    self.xml.get_widget
("hardware_pixmap").load_file("/usr/share/redhat-config-network/pixmaps/connection-ethernet.png")
AttributeError: 'None' object has no attribute 'load_file'
Comment 1 Trond Eivind Glomsrxd 2001-10-22 11:25:17 EDT
Do you have pygnome installed?
Comment 2 Gregory Leblanc 2001-10-22 11:40:26 EDT
Yep, version 1.4.1-3 is installed.  Rpm's verify on it comes back with no errors
as well.  I don't see redhat-config-network listed in the output of 'rpm -q
--whatrequires pygnome', BTW.
Comment 3 Gregory Leblanc 2001-10-24 02:41:51 EDT
I poked Jonathan to look at this a little this evening, but we didn't get very
far.  I noticed that this happens at least with 'neat' and 'printtool', but not
with gfloppy.  Something is clearly out of whack.  I ran 'rpm -qa |grep glade
|xargs rpm -V' and that comes back clean.  I'm not sure what else I should look for.
Comment 4 Trond Eivind Glomsrxd 2001-12-03 15:52:00 EST
Is this a clean system?
Comment 5 Gregory Leblanc 2001-12-03 15:55:10 EST
Not particularly.  It was an upgrade from 7.1 and 7.0.
Comment 6 Trond Eivind Glomsrxd 2001-12-03 16:08:46 EST
Can you try it on a clean 7.2 system? I can't reproduce it here... (pygnome has
been added to the requires list since the beta, BTW). Jrb, does this look like
some particular component is missing?
Comment 7 Harald Hoyer 2002-06-26 10:28:11 EDT
Requires: initscripts >= 5.99, usermode , alchemist, kudzu, libglade,
pygtk-libglade, pygtk, python, pygnome-libglade, pygnome, gnome-core
Comment 8 Jay Turner 2002-08-14 14:45:03 EDT
The latest version of redhat-config-network for 7.3 works, as does the version
that we have in the public beta trees.

Note You need to log in before you can comment on or make changes to this bug.