Bug 54904 - Keyboard shortcut problem
Keyboard shortcut problem
Status: CLOSED DUPLICATE of bug 51172
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 18:32 EDT by adam.huffman
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 20:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-10-22 18:32:42 EDT
Description of Problem:
The installed shortcuts for changing workspaces and windows etc.
do not work.

Version-Release number of selected component (if applicable):
0.38-11

How Reproducible:
Every time

Steps to Reproduce:
1. login and start gnome
2. try one of the default shortcuts
3. 

Actual Results:
The window modifier key is not used.

Expected Results:
The window modifier key is used and the shortcut works.

Additional Information:
Comment 1 Havoc Pennington 2001-10-23 11:31:43 EDT
Which shortcuts do you mean? Do they work with control instead of alt?
Comment 2 adam.huffman 2001-10-23 11:35:06 EDT
The shortcuts to switch between different windows and to change to a different
desktop/workspace e.g. M-F1, M-Tab.

They didn't work with control either.
Comment 3 Havoc Pennington 2001-10-23 11:43:33 EDT
If you run "xev" and type the shortcuts into that, what does it output for the
key press event?
Comment 4 adam.huffman 2001-10-23 20:18:11 EDT
Here's what I get with Alt-Tab:KeyRelease event, serial 23, synthetic NO, window
0x1c00001,
    root 0x32, subw 0x0, time 3151431874, (894,598), root:(924,660),
    state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
"   XLookupString gives 1 characters:  "

KeyPress event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151440676, (894,598), root:(924,660),
    state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyPress event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151441002, (894,598), root:(924,660),
    state 0x8, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 characters:  "        "

KeyRelease event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151441136, (894,598), root:(924,660),
    state 0x8, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 characters:  "        "

KeyRelease event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151441160, (894,598), root:(924,660),
    state 0x8, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

and here's what I get for Ctrl-Tab:


KeyRelease event, serial 17, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151508223, (803,447), root:(833,509),
    state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
"   XLookupString gives 1 characters:  "

KeyPress event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151511289, (803,447), root:(833,509),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyPress event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151511723, (803,447), root:(833,509),
    state 0x4, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 characters:  "        "

KeyRelease event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151511859, (803,447), root:(833,509),
    state 0x4, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 28, synthetic NO, window 0x1c00001,
    root 0x32, subw 0x0, time 3151511867, (803,447), root:(833,509),
    state 0x0, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 characters:  "        "
Comment 5 Havoc Pennington 2002-03-01 10:27:19 EST

*** This bug has been marked as a duplicate of 51172 ***

Note You need to log in before you can comment on or make changes to this bug.