Bug 54910 - tcltk-8.3.3-65.src.rpm - wish not found and tested in PATH of build process
tcltk-8.3.3-65.src.rpm - wish not found and tested in PATH of build process
Status: CLOSED DUPLICATE of bug 52606
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 23:41 EDT by R P Herrold
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 00:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-10-22 23:41:26 EDT
Rebuilding  /tcltk-8.3.3-65.src.rpm without a pre-existing version 
installed.  Note that although 'find' sees the 'wish' produced (but NOT 
in the ../bin subpart of the path), RPM has not been offered the correct 
path -- 

looks like it needs to have %{Buildroot}/tcl8.3.3/unix/ added

checking for build with symbols... no
checking for tclsh... (cached) 
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix/tclsh
checking for wish... configure: error: No wish found in PATH:  /usr/bin 
/usr/bin /usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix 
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix/../bin /usr/local/sbin 
/usr/sbin /sbin /usr/local/sbin /usr/local/bin /sbin /bin /usr/sbin 
/usr/bin /usr/X11R6/bin /root/bin
configure: error: ./configure failed for itk
error: Bad exit status from /var/tmp/rpm-tmp.98319 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.98319 (%build)

[root@ SPECS]# find /usr/src/redhat/BUILD/tcltk-8.3.3/ -name \       wish 
| grep wish$

/usr/src/redhat/BUILD/tcltk-8.3.3/tk8.3.3/unix/wish
Comment 1 R P Herrold 2002-06-30 01:17:26 EDT
 This is STILL unresolved ... What is the problem: 
 
 
checking for existence of /usr/src/redhat/BUILD/tcltk-8.3.3/tk8.3.3/unix/tkConfig.sh... loading 
checking for name if Itcl stub library... (cached) libitclstub.a 
checking for tkstub library... -L/usr/lib -l 
checking for itclstub library... -L/usr/lib -l 
checking for Tcl private include files... Using srcdir found in tclConfig.sh: 
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3 
checking for Tk private include files... Using srcdir found in tkConfig.sh 
checking for building with threads... no (default) 
checking how to build libraries... shared 
checking for build with symbols... no 
checking for tclsh... (cached) /usr/bin/tclsh 
checking for wish... configure: error: No wish found in PATH:  /usr/bin /usr/bin 
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix /usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix/../bin /bin /sbin 
/usr/bin /usr/sbin /usr/local/bin /usr/local/sbin /usr/bin/X11 /usr/X11R6/bin /root/bin 
configure: error: ./configure failed for itk 
error: Bad exit status from /var/tmp/rpm-tmp.39484 (%build) 
 
 
RPM build errors: 
    Bad exit status from /var/tmp/rpm-tmp.39484 (%build) 
[root@router dl]# df 
Filesystem           1k-blocks      Used Available Use% Mounted on 
/dev/hda3               390472    166325    203987  45% / 
/dev/hda1                29249      2914     24825  11% /boot 
/dev/hda5               964312    848916     66412  93% /usr 
/dev/hdc1              4166504   3575776    379076  91% /var/ftp/pub 
none                     15060         0     15060   0% /dev/shm 
 
[root@router dl]# head -20  /usr/src/redhat/SPECS/tcltk.spec 
%define tcl_major       8.3 
%define tk_major        8.3 
%define tclx_major      8.3 
%define expect_major    5.32 
%define tix_major       8.2.0 
 
%define tclvers         %{tcl_major}.3 
%define tkvers          %{tk_major}.3 
%define tclxvers        %{tclx_major} 
%define expvers         %{expect_major}.2 
%define tixvers         %{tix_major}b1 
%define itclvers        3.2 
%define tcllibvers      1.0 
 
Summary: A Tcl/Tk development environment: tcl, tk, tix, tclX, expect, and itcl. 
Name: tcltk 
Version: %{tclvers} 
Release: 68 
Source0: ftp://tcl.activestate.com/pub/tcl/tcl8_3/tcl%{tclvers}.tar.bz2 
Source1: ftp://tcl.activestate.com/pub/tcl/tcl8_3/tk%{tclvers}.tar.bz2 
[root@router dl]# 
Comment 2 R P Herrold 2002-06-30 01:21:30 EDT
  
I opened a build path error 8 months ago -- it is still 
unaddressed and unfized in the current rawhide.. 
 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=54910 
 
If clean builds are occurring, it means that the build 
environment is using a wish other than the locally produced 
one in the compile path.  This of course defeats the purpose 
of the tests which are in the tcltk Makefile tree. 
 
I am bouncing this to a High level.. 
 
-- Russ Herrold 
 
 
Comment 3 R P Herrold 2002-07-27 17:23:30 EDT
This bug is still present on tcltk-8.3.3-69:

bash-2.05a$ sudo rpm -Uvh 
/var/ftp/pub/mirror/redhat/beta/i386/SRPMS/SRPMS/tcltk-8.3.3-69.src.rpm

...
checking for tclsh... (cached) /usr/bin/tclsh
checking for wish... configure: error: No wish found in PATH:  /usr/bin /usr/bin
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix
/usr/src/redhat/BUILD/tcltk-8.3.3/tcl8.3.3/unix/../bin /usr/local/sbin /usr/sbin
/sbin /bin /usr/bin /usr/bin/X11 /usr/local/bin /usr/bin /usr/X11R6/bin
configure: error: ./configure failed for itk
error: Bad exit status from /var/tmp/rpm-tmp.18664 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.18664 (%build)
bash-2.05a$ rpm -q expect
package expect is not installed
Comment 4 R P Herrold 2002-07-27 17:25:56 EDT
Bugzilla 52606
Comment 5 Jens Petersen 2002-08-14 06:07:27 EDT

*** This bug has been marked as a duplicate of 52606 ***
Comment 6 Jens Petersen 2002-08-14 06:09:07 EDT
Thanks for the report and your patience - I will try to look into this
before too long.
Comment 7 Jens Petersen 2002-10-23 02:09:11 EDT
Yes, it only seems to build with tk installed currently. :-\

Fix should be forthcoming.

Note You need to log in before you can comment on or make changes to this bug.