Bug 54954 - OpenGL on Voodoo 5 displays incorrectly
OpenGL on Voodoo 5 displays incorrectly
Status: CLOSED DUPLICATE of bug 52950
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks: 82778
  Show dependency treegraph
 
Reported: 2001-10-23 13:39 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-23 13:39:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
OpenGL examples (like gears from the Mesa-demos package) display 
incorrectly on a Voodoo 5 5500 when using Direct Rendering. Some or all 
polygons are "stretched" down and to the left.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.2 on a machine with a Voodoo 5 5500 (make sure the Mesa and 
Mesa-demos RPMs are installed.
2. Run "gears".
3. Set LIBGL_ALWAYS_INDIRECT=TRUE in your environment (and export)
4. Run "gears" again.

Actual Results:  The first time you run "gears" you will see the gears 
displayed incorrectly - they will seem to be stretched down and to the 
left. The second time (with indirect rendering) they will be displayed 
correctly.

Expected Results:  Both cases should display the same.

Additional info:

This works correctly if you use the X Server from dri.sourceforge.net.
Comment 1 WHITNEY BATTESTILLI 2001-10-23 21:54:56 EDT
I had the same problem.  Voodoo 5 on a fresh 7.2 with the exact visual 
distortion.  I fixed it by pulling the source of glide.sourceforge.net and 
compiling.  (Don't enable amd 3Dnow or it won't work).  I think that I had 
this same problem before.  I would guess that the XFree86 guys have a < 
up-to-date version of Glide in their tree.

Whitney Battestilli
whitney@nc.rr.com
Comment 2 Need Real Name 2001-10-23 22:24:19 EDT
Yup, you're right. I installed a CVS Glide (I had an RPM from when I was playing
with DRI) and it displays fine now. Definitely Red Hat needs to upgrade the
Glide libraries in it's XFree86 RPMs.

Thanks for the info!
Comment 3 Mike A. Harris 2001-10-26 21:39:38 EDT
wbpublic@nc.rr.com:  Actually...  There is no Glide at all in the
XFree86 tree.  Glide doesn't come as part of XFree86 source.  That
said, the Glide3 that comes with Red Hat Linux, is supplied in the
XFree86 RPM packages, which may be a cause for the confusion.

There are some issues with the Voodoo 4/5 that people claim is fixed
by recompiling, however I haven't been able to see/test this because
I do not actually have this hardware.  I plan on obtaining one though
and testing this out.  It is possible our build process may have a
flaw in it perhaps.
Comment 4 Need Real Name 2002-01-24 21:26:58 EST
This is still happening with the 4.2 SRPMs from Rawhide - I built these on 7.2
and saw the same problem.
Once again, building a new Glide from the sourceforge CVS tree works.
Comment 5 Mike A. Harris 2002-03-14 09:53:50 EST
The Glide3 package we ship *IS* a Glide checkout from sourceforge CVS.
This implies that the actual Glide3 build itself is failing somehow.

I had a Voodoo 5 shipped to me that unfortunately died upon arrival,
so I am still not able to actually see it with my own eyes and test
build it until I see it working as you describe.
Comment 6 Mike A. Harris 2002-12-19 04:24:14 EST

*** This bug has been marked as a duplicate of 52950 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:48:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.