Bug 54975 - netconfig --nameserver doesn't work
netconfig --nameserver doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 17:18 EDT by David Morse
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 13:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patches net.c to allow use of --nameserver option...basically just calls writeResolvConf for the netdev struct (376 bytes, patch)
2002-03-05 16:15 EST, James McDermott
no flags Details | Diff
SRPM with patch already included in spec file (52.29 KB, application/octet-stream)
2002-03-05 16:16 EST, James McDermott
no flags Details

  None (edit)
Description David Morse 2001-10-23 17:18:45 EDT
From Bugzilla Helper:

Description of problem:
Upon a "netconfig -?", --nameserver=STRING is showed as an option to 
specify the nameserver for an interface.  However, instead of adding the 
appropriate DNS1 entry to ifcfg-ethN, it doesn't seem to do anything.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run /usr/sbin/netconfig --device=eth0 --ip=192.1.8.56 --
netmask=255.255.255.0 --gateway=192.1.8.33 --nameserver=192.1.8.33
2. ifdown/ifup interface
3. Note that /etc/resolv.conf does not have a "nameserver" entry, since 
DNS1 is not specified in /etc/sysconfig/network-scripts/ifcfg-eth0.


Actual Results:  The nameserver I specified is not available (no DNS1 
entry in ifcfg-eth0)

Expected Results:  As a result of the above command, ifcfg-eth0 should 
have the line
DNS1=192.1.8.33


Additional info:

--nameserver doesn't seem to work as advertised in the netconfig Usage 
screen.

(as a side note, netconfig was not available as a Component choice in 
Bugzilla, even though it has been broken out from the pump package -- 
this should probably be added)
Comment 1 James McDermott 2002-03-05 16:10:32 EST
Attaching patch and source rpm with fixes for this bug.
Comment 2 James McDermott 2002-03-05 16:15:21 EST
Created attachment 47481 [details]
Patches net.c to allow use of --nameserver option...basically just calls writeResolvConf for the netdev struct
Comment 3 James McDermott 2002-03-05 16:16:27 EST
Created attachment 47482 [details]
SRPM with patch already included in spec file
Comment 4 David Morse 2002-03-06 17:50:04 EST
Confirmed fix works.
Comment 5 Matt Domsch 2003-02-13 13:05:31 EST
Fix confirmed above, closing.

Note You need to log in before you can comment on or make changes to this bug.