This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 549861 - X does not start on Acer Aspire One
X does not start on Acer Aspire One
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 15:26 EST by Karel Volný
Modified: 2010-01-13 05:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 05:55:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-12-22 15:26:16 EST
Description of problem:
I've installed Fedora 12 on an USB stick - I mean full installation, not "Live" - and I am trying to use it with Acer Aspire One, but X does not start.
I cannot switch to text mode using Ctrl+Alt+Fx, but I can ssh into the machine.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.31.6-166.fc12.i686

How reproducible:
always (for me, on each boot from this stick)

Steps to Reproduce:
1. try to boot Fedora from USB stick on Acer Aspire One
  
Actual results:
the wallpaper with Fedora symbol in the middle is displayed forever

Expected results:
normal X environment

Additional info:
I suspect it is a kernel problem because of the last message:

[root@usbstick ~]# dmesg | grep drm
[drm] Initialized drm 1.1.0 20060810
fbcon: inteldrmfb (fb0) is primary device
[drm] LVDS-8: set mode 1024x600 e
fb0: inteldrmfb frame buffer device
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

The X doesn't seem to get past basic initialisation:

[root@usbstick ~]# cat /var/log/Xorg.0.log

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5
Current Operating System: Linux usbstick 2.6.31.6-166.fc12.i686.PAE #1 SMP Wed Dec 9 11:00:30 EST 2009 i686
Kernel command line: ro root=UUID=a1c9c219-0f89-454b-8985-fb01739fd069  LANG=cs_CZ.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
Build Date: 05 November 2009  07:43:20PM
Build ID: xorg-x11-server 1.7.1-7.fc12
Current version of pixman: 0.16.4
        Before reporting problems, check http://bodhi.fedoraproject.org/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 22 20:51:20 2009
(II) Loader magic: 0x821b0a0
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(++) using VT number 7


and the graphics card info:

[root@usbstick ~]# lspci -v -s 00:02
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Device 015b
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at 58480000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 60c0 [size=8]
        Memory at 40000000 (32-bit, prefetchable) [size=256M]
        Memory at 58500000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
        Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
        Subsystem: Acer Incorporated [ALI] Device 015b
        Flags: bus master, fast devsel, latency 0
        Memory at 58400000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2
Comment 1 Karel Volný 2010-01-10 12:57:41 EST
note that without graphical boot (i.e. removing rhgb from kernel line in grub) the system starts just fine ... this sounds soooo similar to the bug #551310 but not a dupe since the machine has LXDE and not KDE; in addition, X startup hangs differently, without the "Interrupted system call" message

however, I have found that a bug #539709 that deals with the drm error message was filed already ... but reading the comments, it seems unrelated to the issue I'm trying to solve in this bug, as I don't end up with "Boot has failed, sleeping forever." message or the other behaviour described for that bug

that leads me to a conclusion that this particular bug lies rather somewhere in lxdm, thus reassigning
Comment 2 Christoph Wickert 2010-01-12 16:36:24 EST
Hi, thanks for your report.

I'm afraid this is SELinux. Corrently lxdm will not run in enforcing mode. See bug 552885 for details. Can you please try with SELinux in permissive mode?
Comment 3 Christoph Wickert 2010-01-12 16:42:25 EST
And another thing to test, please forgive me because if it too trivial: Does LXDM running on another console and the display doesn't switch from VT1 (plymouth) to VT7 (lxdm)? I have fixed this in the latest lxdm update, lxdm now uses VT1. 

Please try https://admin.fedoraproject.org/updates/F12/FEDORA-2010-0381
Comment 4 Karel Volný 2010-01-13 05:55:51 EST
(In reply to comment #3)
> And another thing to test, please forgive me because if it too trivial: Does
> LXDM running on another console and the display doesn't switch from VT1
> (plymouth) to VT7 (lxdm)? I have fixed this in the latest lxdm update, lxdm now
> uses VT1. 
> 
> Please try https://admin.fedoraproject.org/updates/F12/FEDORA-2010-0381    

yes, it works, X runs on VT1 now and the login screen appears

thanks!

Note You need to log in before you can comment on or make changes to this bug.