Bug 549965 - Slow emulation in QEMU because of disabled kqemu
Slow emulation in QEMU because of disabled kqemu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 23:02 EST by Igor A Tarasov
Modified: 2010-03-30 10:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 10:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch configure script to allow kqemu (383 bytes, patch)
2009-12-22 23:02 EST, Igor A Tarasov
no flags Details | Diff

  None (edit)
Description Igor A Tarasov 2009-12-22 23:02:10 EST
Created attachment 379971 [details]
Patch configure script to allow kqemu

kqemu disabled in any case because of bug in configure script:

linux_user="yes"
usb="linux"
kvm="yes"
if [ "$cpu" = "i386" -o "$cpu" = "x86_64" ] ; then
    kqemu="yes"
    audio_possible_drivers="$audio_possible_drivers fmod"
    kvm="yes"
    kqemu="no"
...

There are 2 lines with kqemu="yes", then kqemu="no". So kqemu is always no :(
Please, fix it and rebuild for public repository.
Comment 1 Glauber Costa 2009-12-24 06:15:04 EST
kqemu is being deprecated in QEMU upstream, and fedora, as usual, takes the same path. So it is unlikely that we'll have new builds with this feature enabled.

Upstream made it disabled by default in this release, and removed it completely in the next one.
Comment 2 Fedora Admin XMLRPC Client 2010-03-09 12:18:11 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Justin M. Forbes 2010-03-30 10:18:25 EDT
Closing wontfix since kqemu is being deprecated upstream.

Note You need to log in before you can comment on or make changes to this bug.