Bug 55006 - Problem with the french hyphenation
Problem with the french hyphenation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 05:42 EDT by Vincent ALLOY
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 08:17:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
French hyphenation latex test file. (338 bytes, text/plain)
2001-11-09 05:42 EST, Vincent ALLOY
no flags Details

  None (edit)
Description Vincent ALLOY 2001-10-24 05:42:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4m)

Description of problem:
By default, latex does not use french hyphenation. You have to execute
"initex latex.ltx" in the directory /usr/share/texmf/web2c/ and it will
produced a file called latex.fmt in which all is well configurated.
Beware to have only one file latex.ltx because latex uses the first found
latex.ltx file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a latex document.
2. Compile it.
3. Look at the result.
	

Actual Results:  The dvi document is created bu without any hyphenation.

Expected Results:  A dvi document with hyphenation (french in my case).

Additional info:

All is well pre-configurated in the distribution. You just have to execute
"initex latex.ltx" in the directory /usr/share/texmf/web2c.
Beware to have only one file latex.ltx because latex uses the first found
latex.ltx file.
Comment 1 Tim Waugh 2001-10-24 05:45:05 EDT
Please submit a short file that I can use to test whether French hyphenation 
is working (I don't know what special rules there are for it).

What does 'rpm -q tetex' say?
Comment 2 Vincent ALLOY 2001-11-09 05:42:08 EST
Created attachment 37003 [details]
French hyphenation latex test file.
Comment 3 Vincent ALLOY 2001-11-09 05:44:07 EST
rpm -q tetex
tetex-1.0.7-7
Comment 4 Tim Waugh 2001-11-09 08:17:51 EST
I don't have 'french.sty'.  Is that the problem you're referring to?

If not, I don't really know what I'm looking at.  Here's what I get when I 
comment out the \usepackage{french} line with tetex-1.0.7-7:

This is TeX, Version 3.14159 (Web2C 7.3.1)
(fr.tex
LaTeX2e <1999/12/01> patch level 1
Babel <v3.6Z> and hyphenation patterns for american, french, german, ngerman, 
i talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 1999/09/10 v1.4a Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/base/inputenc.sty
(/usr/share/texmf/tex/latex/base/latin1.def))
(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/t1enc.def))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/english.ldf
(/usr/share/texmf/tex/generic/babel/babel.def))
(/usr/share/texmf/tex/generic/babel/frenchb.ldf))
No file fr.aux.
(/usr/share/texmf/tex/latex/cyrillic/ot2wncyr.fd)
Underfull \hbox (badness 10000) in paragraph at lines 7--7
[] \T1/cmr/m/n/10 si-gnal contai-ner ivi-ne-ment al-ghbre

Underfull \hbox (badness 10000) in paragraph at lines 8--8
[] \T1/cmr/m/n/10 ivh-ne-ments al-ghbre dis-wu-vre-ment nai-ve-tis

Underfull \hbox (badness 10000) in paragraph at lines 10--10
[] \T1/cmr/m/n/10 sig-nal con-tainer
(fr.aux) )
(see the transcript file for additional information)
No pages of output.
Transcript written on fr.log.

And here's the output from the latest package (which will become 1.0.7-37):

This is TeX, Version 3.14159 (Web2C 7.3.1)
(fr.tex
LaTeX2e <2000/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, 
i talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2000/05/19 v1.4b Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/base/inputenc.sty
(/usr/share/texmf/tex/latex/base/latin1.def))
(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/t1enc.def))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/english.ldf
(/usr/share/texmf/tex/generic/babel/babel.def))
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
*************************************
* Local config file frenchb.cfg used
*
(/usr/share/texmf/tex/generic/babel/frenchb.cfg)))
No file fr.aux.
(/usr/share/texmf/tex/latex/cyrillic/ot2wncyr.fd)
Underfull \hbox (badness 10000) in paragraph at lines 7--7
[] \T1/cmr/m/n/10 si-gnal contai-ner ivi-ne-ment al-ghbre

Underfull \hbox (badness 10000) in paragraph at lines 8--8
[] \T1/cmr/m/n/10 ivh-ne-ments al-ghbre dis-wu-vre-ment nai-ve-tis

Underfull \hbox (badness 10000) in paragraph at lines 10--10
[] \T1/cmr/m/n/10 sig-nal con-tainer
(fr.aux) )
(see the transcript file for additional information)
No pages of output.
Transcript written on fr.log.

Running 'initex latex.ltx' produces no different output.  Can you give me more 
detail about how to see the problem you are describing?
Comment 5 Tim Waugh 2001-11-22 05:39:56 EST
Closing this report, as the current package seems to handle French 
hyphentation properly.

Note You need to log in before you can comment on or make changes to this bug.