Bug 550126 - Piranha fails to parse load average with "load_monitor = ruptime"
Piranha fails to parse load average with "load_monitor = ruptime"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
: OtherQA, Patch
Depends On:
Blocks: 557162
  Show dependency treegraph
 
Reported: 2009-12-23 12:03 EST by Olivier Fourdan
Modified: 2016-04-26 09:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: piranha-0.8.4-19.el5
Doc Type: Bug Fix
Doc Text:
Previously, the pulse daemon failed to parse the load average using "load_monitor = ruptime". With this update, pulse parses the load average correctly.
Story Points: ---
Clone Of:
: 557162 (view as bug list)
Environment:
Last Closed: 2011-01-13 18:23:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (437 bytes, patch)
2009-12-23 12:03 EST, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2009-12-23 12:03:26 EST
Created attachment 380059 [details]
Proposed patch

Description of problem:

When load_monitor = ruptime is used, nanny seems to throw or fill the syslog's with "bad load average returned" messages.

Version-Release number of selected component (if applicable):

piranha-0.8.4-13.el5 

How reproducible:

Always

Steps to Reproduce:

configure LVS to use ruptime for load monitoring
  
Actual results:

nanny seems to consider the output returned as bad. It may affect the LVS routing table while adjusting the weight factor for each server

Expected results:

nanny should be able to use "ruptime" properly so that it can adjust the weight factor

Additional info:

Attaching patch proposed by Ranjith Rajaram - Our customer has tried the patch. and the weight seems to be adjusted.
Comment 1 Marek Grac 2010-01-20 11:11:02 EST
Thanks, patch is in now part of upstream. 

@test: test with load_monitor=ruptime / load_monitor=ssh

Fixed in upstream:

http://git.fedoraproject.org/git/piranha.git?p=piranha.git;a=commit;h=e6de7e51f478878dea721832ec23173710a0bf44
Comment 6 Marek Grac 2010-12-01 07:34:25 EST
requiring: Running piranha environment

in /etc/sysconfig/ha/lvs.cf:

change "load_monitor = ruptime"

if there are no error messages and load-balancing is working then piranha works
Comment 7 Florian Nadge 2011-01-03 04:46:27 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the pulse daemon failed to parse the load average using "load_monitor = ruptime". With this update, pulse parses the load average correctly.
Comment 10 errata-xmlrpc 2011-01-13 18:23:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0091.html

Note You need to log in before you can comment on or make changes to this bug.