Bug 55015 - login useing more than 8 charachter password and NIS
login useing more than 8 charachter password and NIS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 09:11 EDT by Need Real Name
Modified: 2013-07-02 18:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 09:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-24 09:11:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; SunOS 5.8 sun4u)

Description of problem:
if you have a login with a password that has more than 8 charachters you
can only login using the first 8 .. it doesnt truncate it as it seemed to
in previous versions. ie. if you enter in all 9 charachters it wont let you
login .. you enter in 8 it will. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set password to any password that is 9 charachters
2. try to login (fail)
3. try to login useing the first 8 charachters (pass)
	

Expected Results:  it should truncate everything after the 8th charachter
and let you login

Additional info:
Comment 1 Kurt Swanson 2001-10-30 19:06:51 EST
This was discussed recently in redhat-list.  It seems that the problem is due to
a change in crypt--as the problem only occurs for those using crypt passwords. 
Using authconfig to switch to md5 passwords is a work-around.  However, all
existing users need to enter new passwords--not acceptable for systems with
large numbers of users...
Comment 2 Richard Warner 2001-11-12 19:53:24 EST
The priority of this should be high.  The renders RH 7.2 totally unusable in
multivendor
enterprise environments.
Comment 3 Need Real Name 2001-11-12 22:48:49 EST
There was a pam module  fix posted on redhat's web site on 10/31/2001 in 7.2 erratta/bug fixes... I have installed it on my 7.2 systems and NIS 
logins work just fine now.  Good luck.
Comment 4 Jindrich Novy 2004-09-16 09:00:09 EDT
Hello, this is fortunately not reproducible any more ;-) Closing this.

cheers,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.