Bug 55041 - Sort order of 'ls' is broken.
Sort order of 'ls' is broken.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 14:53 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-24 17:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-24 14:53:05 EDT
Description of Problem:

Sort order of 'ls' is broken.  There is nothing in any of the documentation
about this change of sort order.  What'd you break?

Version-Release number of selected component (if applicable):

RH 7.1

How Reproducible:

Always

Steps to Reproduce:
1. run ls
 

Actual Results:
Something broken

Expected Results:
Something not broken

Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-10-24 17:52:18 EDT
I'm not seeing anything broken in there. Please attach a test case.

If you're referring to the fact that the sort order is

a
Ab
b

rather than

Ab
a
b

That's because your locale is case insensitive and you can return to the old 
behavior by setting LC_COLLATE=C in /etc/sysconfig/i18n.
This has been the case ever since locale support was added to the GNU tools.

Is that what you're talking about?
Comment 2 Bernhard Rosenkraenzer 2001-10-30 08:10:52 EST
Assuming my assumption was correct due to lack of feedback.


Note You need to log in before you can comment on or make changes to this bug.